[mythtv-users] Absolute links in mythweb

Mike stuff at dustsmoke.com
Tue Apr 4 09:49:17 UTC 2006

Ben Holt wrote:
> Hi All,
> I recently upgraded from 0.18 to 0.19 and along the way discovered
> that mythweb, at least in its Debian packaged form, is now using
> absolute instead of relative links throughout.
> Outside my LAN mythweb is made available through a reverse proxy from
> my LAN's main web server at an URL such as
> https://www.mylansserver.com/mythtv while within the LAN it is
> available directly from my myth server with an URL like
> http://mymythserver.  As you might imagine the change to absolute
> links completely breaks mythweb access via my reverse proxy.
> Can someone suggest a relatively simple fix for this?  Any idea what
> the rational for changing from relative to absolute links was?
> - Ben

I use a reverse reverse proxy. I have to bounce it twice from an 
external web server, to my lan server on a high port, to my backend on 
80 again because I want to get to it from a normal port since cox wont 
let me use 80 or 443. Granted I'm not using the debian packages on my 
sarge based system. Everything on it is built from source.

Without knowing more about the packages you installed, (like which ones 
and how the maintainer has them installed.) Its hard to be much help 
past saying "it works for me from source, mod_rewrite and all". If I 
looked at it I could tell you whats wrong, but its hard to say sitting here.

One thing you could try is to get mythweb from the plugins source file 
and copy it over to /var/www/mythweb if that doesn't already exist. See 
if it works from there with default files.


More information about the mythtv-users mailing list