[mythtv-users] Nuvexport problems ffmpeg finishes immediately.

chris at cpr.homelinux.net chris at cpr.homelinux.net
Sun Nov 13 02:01:25 EST 2005

On Sat, Nov 12, 2005 at 02:37:30PM -0800, Chris Petersen wrote:
> >yuvdenoise: invalid option -- r
> Your error is right there.  Turn off denoise until the mjpegtools people 
> stop changing their cli options so much.

The problem is larger than that.  As the parent message indicated, if you
turn off denoise then the error is different but the nuvexport still
fails.  I ran "nuvexport --debug" and tried to export to VCD with all
optional processing disabled.  The result were:

/usr/bin/nice -n19 mythtranscode --showprogress -p autodetect -c 1039 -s
2005-08-18-01-15-00 -f "/tmp/fifodir_18246/" 2>&1

/usr/bin/nice -n19 ffmpeg -hq -y -f s16le -ar 48000 -ac 2 -i 
/tmp/fifodir_18246/audout -f rawvideo -s 720x480 -aspect 
1.33333333333333 -r 29.970 -i /tmp/fifodir_18246/vidout -aspect 1.3333 
-r 29.97 -s 352x240  -b 1150 -vcodec mpeg1video -ab 224 -ar 44100 
-acodec mp2 -f vcd "./Pulp Fiction.mpg" 2>&1

I cut-n-paste the latter command to the shell and got the following reply:

ffmpeg version CVS, build 3276800, Copyright (c) 2000-2004 Fabrice Bellard
  configuration:  --build i486-linux-gnu --enable-gpl --enable-pp 
--enable-zlib --enable-vorbis --enable-libogg --enable-theora 
--enable-a52 --enable-dts --enable-dc1394 --enable-libgsm 
--disable-debug --prefix=/usr built on Sep 22 2005 15:30:03, gcc: 4.0.2 
20050913 (prerelease) (Debian 4.0.1-7)
ffmpeg: unrecognized option '-hq'

If I strip the '-hq' option then I get a more reasonable error (because 
the fifo is empty) but at least it accepts all of the command line 

It looks like the mjpegtools people are innocent this time?  In any 
case, it might not be a bad idea if mythtranscode checked the process 
exit status of ffmpeg and threw an error back to nuvexport so it could 
end noisily.

More information about the mythtv-users mailing list