[mythtv-users] stuttering playback with MythTV EPIA-M/networked

Thomas Aeby aeby at graeff.com
Fri May 20 12:29:08 UTC 2005


I am trying to use MythTV in a configuration where the backend is
running on a central "media server" and playback goes via network on
mythfrontend running on an VIA EPIA based box.

Unfortunately playback on the VIA based box is stuttering, thus it plays
well for half a second or so, then stops for 1/3 second (video and
sound), then plays for another half a second, stutters again ...

Don't take "0.5 second" and 1/3 second for exact figures ...

What I have already thought about:

  - Problems on the capturing side:
    I can watch TV on the "media server" without any problems, so the
    backend side does not seem to be the problem.

  - Performance problems / failing MPEG hardware decoder (XvMC)
    I think this is not the problem since I have another box (Pentium
    III/700 without any hardware accelerated video) - when I try to 
    watch TV on this second box I just get a very poor framerate all
    over the time but no stuttering like described. So I assume XvMC
    is basically online since without XvMC playback would rather
    resemble that of the other slow box.

  - network problems
    In order to make sure network is not the problem I tried various
    ring buffer sizes ... and I even tried starting TV, unplug the
    network and see what happens: It keeps playing *and*stuttering*
    for another few seconds (buffer) and then stops. So it seems that
    the stuttering is not caused by network problems since the buffer
    seems to be full and the problem does not go away during playback
    from buffer only.

  - .... any other idea????

Many thanks in advance for any hints!

Best regards,
Thomas Aeby, Kirchweg 52, 1735 Giffers, Switzerland, Tel: (+41)264180040
Internet: aeby at graeff.com                       PGP public key available

More information about the mythtv-users mailing list