[mythtv-users] No sound from PVR-500 Tuner, working with Line In

Stefan Wrobel swrobel at gmail.com
Wed Jun 22 17:06:43 UTC 2005

I'm totally stumped on this one, I spent a few hours on it last night and I 
just can't get sound from the tuner. Here's the situation.

I'm using a PVR-500 and I've only gotten /dev/video0 working. The second 
tuner seems to be detected in my dmesg, but /dev/video1 is not working like 
it should and ivtvctl -d /dev/video1 -a shows really strange negative values 
for brightness, contrast, etc. Just thought I'd throw that in there, but 
that's only the beginning of my problems. I want to get sound working before 
I worry about having both tuners.

I've captured stuff using the s-video input and the line in, and I can get a 
video file with sound using cat /dev/video0 > test.mpg (and tested in Myth 
as well, it captures video, no audio). I think I did ivtvctl -p 0 -q 2 for 
that. However, using ivtvctl -p 6 (or 7, i've tried both) -q 0 (i've tried 
the other -q values as well, but -q 0 should be tuner audio), I get a 
perfect video file from whatever channel I'm tuned to, but no sound. I 
assume the line in and tuner both use the same audio encoder, so I don't get 
why I wouldn't be getting any sound from one but not the other! I think that 
also rules out modules being loaded improperly, etc.

Does anyone have any experience with this? I'm pulling my hair out at this 
point. I'm using ivtv version 0.3.6m. Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20050622/1081006c/attachment.htm

More information about the mythtv-users mailing list