[mythtv-users] Mythfilldatabase auto run - again sorry

Ant Daniel antdaniel at gmail.com
Tue Jun 21 07:11:05 UTC 2005

On 6/20/05, Matt White <whitem at arts.usask.ca> wrote:
> Ant Daniel wrote:
> > I get a similar problem, the problem for me is that as mythbackend is
> > running as root, it doesn't locate the configure files.
> >
> > In /var/log/mythtv/mythfilldatabase I get the error message
> > config file //.mythtv/Satellite.xmltv does not exist, run me with --configure
>                ^^
> This would tend to indicate that the environment variable $HOME doesn't
> exist, which means it also doesn't probably exist in the mythbackend
> process environment (it should inherit it when the backend forks
> mythfilldatabase).  When in your startup are you starting mythbackend?

It's started during boot up /etc/init.d/mythbackend

> > I haven't yet found a solution, short of running is manually. I tried
> > running mythbackend as mythtv user but on FC3 that seems to cause
> > other problems. I also tried to pass the file in the arguments using
> > --graboptions "--configure /home/mythtv/.mythtv/Satellite.xmltv" but
> > this doesn't seem to work either.
> If you're running mythfilldatabase as root and it works, then the config
> file is probably in /root/.mythtv/whatever and not in /home/mythtv.
> I suppose that a (very nasty) workaround would be to explicitly set
> $HOME in your mythbackend startup script before starting the backend:
> HOME=/root
> export HOME
> The thing is, it should be set...

The thing is that I have to (currently) run mythbackend as root, but I
don't want to keep all the config data in root, but in mythtv.

Adding the --graboptions --config-file
"/home/mythtv/.mythtv/Satellite.xmltv" appears to work for me. It got
updated last night, although MythWeb Backend status reports it as
'currently running' and it isn't.

More information about the mythtv-users mailing list