[mythtv-users] IR Blaster: possible serial port problem

Pete Stagman tyrstag at gmail.com
Sun Jun 12 11:50:59 UTC 2005

 Have you tried controlling your receiver? I couldn't see the flashes from 
my blaster in a digital camera, some cameras have stronger IR filters than 
I hooked it up to my receiver and it worked.

 On 6/11/05, Nick <knowledgejunkie at gmail.com> wrote: 
> On 6/11/05, Drew Zerdecki <dzerdecki at gmail.com> wrote:
> >
> > I do have a PVR-350 and use its IR receiver, which I have read is on
> > COM1. I have tried both COM1 and COM2 settings in modprobe.conf,
> Not the case. The Hauppauge cards use their own interface via i2c (the
> LIRC module is lirc_i2c) to enable the IR receiver to work. It doesn't
> touch the COM ports at all.
> > mathcing the serial irq settings of my BIOS. Is there a way for me to
> > ensure that my serial port is working? Would I make a serial
> > connection with my laptop's hyperterminal? What would be the easiest
> > way to ensure /dev/ttytS0 or S1 is outputting anything?
> If you have another machine with a spare COM port, you could try to
> connect the two together, and then send and receive to ensure the port
> is working consistently. Alternatively, if the other machine is
> running linux you could try the blaster on that machine too (or use a
> live CD to test it).
> If there is a single COM port, it is likely set as COM1 with address
> 0x3f8, and IRQ 4. (Check the BIOS on messages on boot to confirm this)
> When I had a machine using a receiver on the Hauppauge card and a
> blaster on the serial port, I had to build 2 separate instances of
> LIRC to control them. The details are explained here:
> http://losdos.dyndns.org:8080/public/mythtv-info/MythTV_DISH_IR_LED_TX_via_Modified_LIRC.html
> The second instance has its own config, own remotes definitions, and
> own running modified LIRC instance. You need to remove the kernel
> serial driver from using the device before you modprobe lirc_serial
> which will control the device. Assuming the correct device nodes exist
> for the second instance, and that the physical device actually works,
> you should be up and running.
> If you've followed the instructions on lircsetup and still got
> nowhere, I'd try to see if you can tell if the device works before
> spending a lot more time trying to configure it. It's pretty much a
> case of installing LIRC, supplying the correct remotes definition file
> for the blaster, and starting it up. It may be easier to first
> stop/remove the LIRC process using the Hauppauge card whilst you are
> trying to verify the blaster is working, as you only need to worry
> about having a single working instance of LIRC for the blaster. When
> it's up and running, you can then add back the IR receiver LIRC
> instance and should then have both running.
> HTH,
> Nick
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Lirc, FC3, and an Irblaster?
www.lircsetup.com <http://www.lircsetup.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20050612/22399363/attachment.htm

More information about the mythtv-users mailing list