[mythtv-users] OSD reports incorrect position and time; other problems

Jos Hoekstra joshoekstra at gmx.net
Sat Jun 11 11:51:47 UTC 2005

John Stubbs schreef:

> Hi All,
>   I'm having multiple annoying issues with my mythtv setup, which is 
> 0.18 running on Fedora Core 3:
> -for some recorded shows, when playing back the recording, the length 
> of the show on the OSD (as shown when 'pause' is hit, for example) is 
> incorrect, that is, for a 30 minute show, it only shows 10:50 instead 
> of 30:00 when there really is 30 minutes recorded- you can let it play 
> through, and it will play for 30 minutes.

Same here, seems to be only after commercial flagging somehow. 
Non-flagged shows have no problems. Bookmarks after the 'end' according 
tp the osd are kept though.

> -when the above behavior occurs, attempting to skip ahead or jump 
> ahead beyond the time given by the OSD, playback will freeze up and 
> only escaping out of play back will work.
same here, except for freezing and stuff. It just plays, but it can't be 
forwarded. Rewinding takes the end according to the osd and then skips back.

> -finally, for some recorded shows, when playing back skip ahead will 
> always jump to the same point, that's too far, i.e. if it's set to 
> skip 30 seconds, it will first skip to say 3:34, then behave normally.

Don't have this

> I don't know much about mysql but I ran the suggested test for a 
> corrupt database (mysqlcheck -r -umythtv -p<password> mythconverg) and 
> everything came back ok.
> I haven't seen anyone else with this problem, so I'm wondering, any 
> ideas?
> John Stubbs

I'm blaming mythcommflag, but I don't know what's causing mythcommflag 
to behave like this. Some channels have little problems others are 
really bad. It seems like the more breaks are detected, the more the osd 
is off.



More information about the mythtv-users mailing list