[mythtv-users] Re: Remote Problem: Need for modifying settings.pro to enable lirc support

CTD ctd at minneapolish3.com
Fri Jun 10 03:02:10 UTC 2005

>  ctd at minneapolish3.com wrote:
> >Need for modifying settings.*pro* to enable lirc support:
> >
> >In general I am trying to get my PVR-350 remote to work and have 
> pieced together
> >info from the mythtv doc and the http://wilsonet.com/mythtv doc.
> >
> >Current system state:
> >After a system startup, irw works correctly so I know that my remote, 
> VPR-350
> >card, and lircd are working. But the remote does not work in mythtv. 
> My current
> >line of attack is to ensure that I have my mythtv compiled to support 
> lirc.
> >
> >Comments:
> >I have read various posts on this subject and have some general 
> guestions.
> >
> >
> >I have seen various posts that mention that mythtv's *setting*.*pro* 
> file must be
> >modified to comment out the following two lines to enable lirc support:
> ># Native lirc support
> >#CONFIG += using_lirc
> >#LIRC_LIBS = -llirc_client
> >
> >I do not see these lines in my *setting*.*pro* (myth0.18.1). Should 
> these be added
> >before compiling? Are these posts for an older version of mythtv?
> >
> >
> No longer required.
> >The 0.18.1 documentation states:
> >"As of MythTV version 0.18, there is no need to edit the 
> settings.*pro* file to set
> >compile-time options."
> >And I see from looking at the configure script that the default for 
> lirce is
> >true: lirc="yes"
> >
> >Later in the lirc section of the myth doc, it then states:
> > "Once you know that your remote is working, you can either recompile 
> MythTV with
> >native lirc support by enabling it in configure ..."
> >
> >Looking at the outoup of running "configure -h", I do not see how one 
> enables
> >this support.
> >
> >
> Automatically used if LIRC is detected. How about posting the output of
> your real configure run so we can see why (if) it's not detected. I.e.
> if you have LIRC installed in some non-standard location, like /opt, you
> would need to add:
> INCLUDEPATH += /opt/include
> LIBS += -L/opt/lib
> to settings.*pro* to enable configure to detect it..
> >So are these any specific steps needed to enable lirc support when 
> compiling mythtv?
> >
> >Other things that I am in the process of confirming:
> >1) /home/mythtv/.lircrc and /home/mythtv/.mythtv/lircrc are globally 
> readable and
> >owned my my mythtv user
> >
> >
> Not necessary. Only needs to be readable by mythtv.

I reran the configure script, and my output can is:

cat: /etc/ld.so.conf.d/*.conf: No such file or directory
cat: /etc/ld.so.conf.d/*.conf: No such file or directory
cat: /etc/ld.so.conf.d/*.conf: No such file or directory
cat: /etc/ld.so.conf.d/*.conf: No such file or directory
# Basic Settings
Compile type     release
Compiler cache   no
DistCC           no
Install prefix   /usr/local
CPU              x86 (AMD Athlon(tm) )
Big Endian       no
MMX enabled      yes
Vector Builtins  no

# Input Support
Joystick menu    yes
lirc support     yes
ivtv support     yes
FireWire support no
DVB support      no [/usr/src/linux-2.6.11-6mdk/include]

# Sound Output Support
OSS support      yes
ALSA support     no
aRts support     no
JACK support     no

# Video Output Support
x11 support      yes
xrandr support   yes
xv support       yes
XvMC support     no
XvMC VLD support no
OpenGL vsync     no
DirectFB         no

Creating config.mak and config.h

After that I did the following for the heck of it:
make clean
qmake mythtv.pro
make install
ran mythfronend as mythtv user and still had same issue


config.h is unchanged

More information about the mythtv-users mailing list