[mythtv-users] 0.18.1 on x86_64 and lirc not working

Jonathan Henry jon.henry at charter.net
Tue Jun 7 01:35:14 UTC 2005


I sincerely thank you for you help. I'm almost there - I have  
followed your instructions precisely but I'm having a build error  
while compiling libmyth. What's weird is ldconfig -p shows libraw1394  
stuff linked so I'm not sure what is going on.

/usr/bin/ld: cannot find -lraw1394
collect2: ld returned 1 exit status
make[2]: *** [libmyth-0.18.1.so.0.18.1] Error 1
make[2]: Leaving directory `/usr/src/redhat/SOURCES/mythtv-0.18.1/ 
make[1]: *** [sub-libmyth] Error 2
make[1]: Leaving directory `/usr/src/redhat/SOURCES/mythtv-0.18.1/libs'
make: *** [sub-libs] Error 2

On Jun 6, 2005, at 2:08 PM, Johan Reinalda wrote:

> Since I posted the original query for help, I've been able to  
> recompile with lirc support.
> You have to change a few things for the linker to find the various  
> libraries.
> I debugged the configure script to see what it was looking for, and  
> then added some to the ldconfig files. Below is the relevant part  
> of my x86_64 build docs, based on Jarod's guide. I should probably  
> post this somewhere, maybe an add on to Jarod's pages ? (It assumes  
> you have yum working; apt doesn't do multi-architecture very well)
> My WAF is very high at the moment; I just replaced 2 400-dics cd- 
> changers and 1 vcr/dvd combo with my mythbox over the weekend, and  
> she loves it!
> Good luck,
> Johan
> ---------
> Building mythtv 0.18.1 from the srpm package.
> As the available x86_64 packages did not support lirc, I decided to  
> rebuild from the source rpms to enable lirc support (leaving the  
> already installed packages loaded)
> First, install prerequisites for building:
> yum install lame-devel
> yum install lirc-lib-devel
> Now download the source package, and install. This goes to /usr/src/ 
> redhat/SOURCES/.
> Here, extract the sources:
> tar -jxvf mythtv-0.18.1.tar.bz2
> now change into the source directory and configure as needed. I run:
> cd mythtv-0.18.1
> ./configure --prefix=/usr --disable-joystick-menu --enable-lirc -- 
> enable-xvmc
> Check the output to make sure all expected things are turned on. -- 
> prefix=/usr sets things to go to the same location as the packages  
> (ie. /usr/bin, /usr/include, etc.), instead of the default /usr/ 
> local, which would result in double copies of the executables.
> I noticed that lirc was not being recognized, even though it's  
> installed. Turns out, the configure script looks for two things:  
> the library, and header (.h) files. The header are installed with  
> the lirc-lib-devel package above, but to fix finding the library, I  
> did:
> 1 - Add file /etc/ld.so.conf.d/lirc-x86_64.conf, containing the line
>    /usr/lib64/
> 2 - now run ldconfig
> You're ready to build!  run 'qmake mythtv.pro', then 'make'.
> If all builds cleanly, run 'make install' (as root)
> Then restart your box (or backend only: "service mythtbackend  
> restart"), and test the new frontend!
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list