[mythtv-users] capture card suddenly doesn't work

Greg Woods greg at gregandeva.net
Sun Jun 5 15:22:41 UTC 2005

I am running mythtv-0.18.1-112.rhfc3.at on Fedora Core 3 (installed from
the at-stable repository via "yum"). I have a pcHDTV-3000 card with the
1.5 version of the driver (the only one I could get to work).

I am literally tearing my hair out over this. I had it working last
night; I even did a delayed recording just to verify that all of that
stuff worked too. Everything looked good. Now the capture card has
suddenly stopped working. All I did was stop and restart mythbackend,
and everything is broken. I have tried rebooting. I have tried dropping
the mythconverg database and completely rebuilding it. Nothing has

The output from dmesg shows that the driver is loaded and the card is

cx2388x v4l2 driver version 0.0.4 loaded
pcHDTV HD3000 Driver Version 1.5
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
ACPI: PCI interrupt 0000:02:01.0[A] -> GSI 10 (level, low) -> IRQ 10
cx8800[0]: found at 0000:02:01.0, rev: 5, irq: 10, latency: 32, mmio:
0xdd000000cx8800[0]: subsystem: 7063:3000, board: pcHDTV HD3000 HDTV
cx8800[0]: i2c register ok
tuner: Ignoring new-style parameters in presence of obsolete ones
tuner: chip found at addr 0xc2 i2c-bus cx8800[0]
tuner: type set to 51 (Thomson DDT 7610 ATSC/NTSC)) by cx8800[0]
cx8800[0]: i2c attach [client=Thomson DDT 7610 ATSC/NTSC)]
cx8800[0]: registered device video0 [v4l2]

But if I fire up the myth-frontend and try to watch TV, I get this in
the log:

2005-06-05 09:05:04.903 Changing from None to WatchingLiveTV
2005-06-05 09:05:04.920 Error: Desired subchannel not specified in
freqid "3", Using 1.
2005-06-05 09:05:05.014 HD5 Error: could not obtain sync
2005-06-05 09:05:19.972 Couldn't read data from the capture card in 15
2005-06-05 09:05:20.000 Changing from WatchingLiveTV to None
2005-06-05 09:08:40.766 DTV ringbuffer not cleaned up!

After this, myth-frontend will return to the initial screen, but if I
hit ESC and try to exit, it hangs (borderless window, zero response
within window) and I have to kill it.

Is there anything I can do to debug or diagnose this short of starting
all the way over from scratch? Anybody seen anything like this before?

Thanks for any help,

More information about the mythtv-users mailing list