[mythtv-users] capture card suddenly doesn't work

Nick knowledgejunkie at gmail.com
Sun Jun 5 16:30:26 UTC 2005

On 6/5/05, Greg Woods <greg at gregandeva.net> wrote:
> I am running mythtv-0.18.1-112.rhfc3.at on Fedora Core 3 (installed from
> the at-stable repository via "yum"). I have a pcHDTV-3000 card with the
> 1.5 version of the driver (the only one I could get to work).
> I am literally tearing my hair out over this. I had it working last
> night; I even did a delayed recording just to verify that all of that
> stuff worked too. Everything looked good. Now the capture card has
> suddenly stopped working. All I did was stop and restart mythbackend,
> and everything is broken. I have tried rebooting. I have tried dropping
> the mythconverg database and completely rebuilding it. Nothing has
> helped.
> The output from dmesg shows that the driver is loaded and the card is
> recognized:
> cx2388x v4l2 driver version 0.0.4 loaded
> pcHDTV HD3000 Driver Version 1.5
> ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
> ACPI: PCI interrupt 0000:02:01.0[A] -> GSI 10 (level, low) -> IRQ 10
> cx8800[0]: found at 0000:02:01.0, rev: 5, irq: 10, latency: 32, mmio:
> 0xdd000000cx8800[0]: subsystem: 7063:3000, board: pcHDTV HD3000 HDTV
> [card=14,autodetected]
> cx8800[0]: i2c register ok
> tuner: Ignoring new-style parameters in presence of obsolete ones
> tuner: chip found at addr 0xc2 i2c-bus cx8800[0]
> tuner: type set to 51 (Thomson DDT 7610 ATSC/NTSC)) by cx8800[0]
> cx8800[0]: i2c attach [client=Thomson DDT 7610 ATSC/NTSC)]
> cx8800[0]: registered device video0 [v4l2]
> But if I fire up the myth-frontend and try to watch TV, I get this in
> the log:
> 2005-06-05 09:05:04.903 Changing from None to WatchingLiveTV
> 2005-06-05 09:05:04.920 Error: Desired subchannel not specified in
> freqid "3", Using 1.
> 2005-06-05 09:05:05.014 HD5 Error: could not obtain sync
> 2005-06-05 09:05:19.972 Couldn't read data from the capture card in 15
> seconds.
> Stopping.
> 2005-06-05 09:05:20.000 Changing from WatchingLiveTV to None
> 2005-06-05 09:08:40.766 DTV ringbuffer not cleaned up!
> After this, myth-frontend will return to the initial screen, but if I
> hit ESC and try to exit, it hangs (borderless window, zero response
> within window) and I have to kill it.
> Is there anything I can do to debug or diagnose this short of starting
> all the way over from scratch? Anybody seen anything like this before?

It looks like it could be that the starting channel for live tv is not
set correctly, and so that card cannot lock to it. If scheduled
recordings work, this would seem likely. If nothing works at all (live
tv or preset recordings) it would follow that the channels setup is
not correct. If you are also trying to watch LiveTV and the last
channel you were watching is now off-air (some UK channels do this
causing live tv to fail) try again when the channel is on-air again
and then try and change channels.

Are you able to use the card outside of Myth? If you can at least this
will narrow the problem down to MythTV.

Sorry I can't help further,

More information about the mythtv-users mailing list