[mythtv-users] Unable to set ALSA parameters

Sage sage at gypsycaravan.com
Tue Jul 26 21:36:18 EDT 2005

I do have a basic .asoundrc file set up.  The contents were in my  
previous message.  It's worked for others so I don't know why it  
wouldn't work for me...  I'm not trying to do any sort of digital  
output or AC-3 passthrough or anything, just straight up analog out.   
Nonetheless, I tried the solutions put forth in that  
DigitalSoundHowTo with no luck.

However, after some fiddling I have noticed that this error does not  
occur if I don't try to play back through the PVR-350.  As soon as I  
start playing through the decoder, ALSA complains.

Also, if use the PVR-350 audio output only, then I get no sound,  
despite looping the audio directly into the sound card.

On Jul 26, 2005, at 6:07 PM, Michael T. Dean wrote:

> Sage wrote:
>> Here's an interesting anomaly I've discovered.  I have an 8 kHz  
>> sound file.  If I play it using aplay:
>> aplay -D default <soundfile>
>> ...then it plays fine.  However, if I use the name of the device  
>> in my .asoundrc file:
>> aplay -D via82xx <soundfile>
>> ...then I get the following output:
>> aplay: set_params:857: Sample format non available
>> This looks like it could be connected to the issue with mythtv.   
>> Does anyone know how to circumvent this problem?
> You know that .asoundrc file that many people tell others to just  
> delete?  Well, it actually does stuff (like format and sample rate  
> conversion for "software" sound cards).  Have a look at http:// 
> mythtv.info/moin.cgi/DigitalSoundHowTo -- even if you're not doing  
> digital sound...
> Mike
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list