[mythtv-users] pcHDTV3000 and PVR-150 together?

Jack Perveiler perveilerj at yahoo.com
Fri Jul 22 11:18:37 EDT 2005

I have a pcHDTV-3000 working in a system with a PVR-500 (which is really 2
PVR-150's on 1 card).  I'm using a variation of 2.6.11 (whatever came with
KnoppMyth r5a16) and things work just fine.

Well, maybe "just fine" is too generous as the myth box is still in its
shakedown period but at least I can tune/record on all 3 tuners without any
problems :)

I'm using the DVB driver (again from KnoppMyth, but I believe they just got it
from pcHDTV.com) for the 3000 (works like a charm) and rev 3.6o of the ivtv
drivers for the 500.  

You definitely can't use one driver for both... I doubt a unified driver
exists.  Usually capture problems in the hauppage cards (especially the 150s
and 500s) can be fixed with a different ivtv driver or card firmware rev (the
newest isn't always the best/most stable).  I went through several ivtv
versions and firmware revisions before settling on the one I have now and the
experience was odd enough that I'll be staying with the working one forever now

Try searching through the mythtv-users and ivtv mailing list archives... you'll
find lots of others with similar problems (many already solved).


--- Greg Woods <greg at gregandeva.net> wrote:

> Has anyone actually successfully used a pcHDTV3000 and a PVR-150
> together in the same machine? In the end, I'd like to use the PVR-150 as
> the main tuner for analog cable, and use the 3000 for OTA HDTV via an
> antenna. Can this be done? Right now I've got FC3 with a 2.6.10 kernel.
> I originally had the 3000 only and the machine worked mostly OK (when I
> didn't mess up the config parameters )-:  I tried adding the PVR-150 and
> installing ivtv, but the new card doesn't work. I can configure it in
> Myth, but tuning to it produces only a black screen with brief streaks
> of color. xawtv segfaults when given /dev/video1.
> I suspect the root of this problem is that I'm trying to use two
> different drivers for two similar devices (as far as the kernel is
> concerned). They are both /dev/video devices with major number 81, so I
> suspect that means I have to find one driver that works for both. I
> don't think I can use v4l (cx*) for the 3000 and then try to use ivtv
> for the 150. Is there a driver that works for both? If not, I'll
> probably remove the 3000 and use the 150 only with ivtv drivers; I
> gather that is known to work and I don't have any HD content yet anyway.
> If I do use two cards, can I use the same video source for both given
> that they are both connected to the same cable source, or would I need
> to create a second exactly identical video source?
> --Greg
> > _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the mythtv-users mailing list