[mythtv-users] Re: [ATrpms-users] mixer always muted in FC4 withnew alsa packages

Chad Sims caslinux at charter.net
Fri Jul 22 08:55:46 EDT 2005

The following worked for me on FC3 with the same problem.

Many people have also encountered trouble with the volume repeatedly being 
muted after reboot (despite adjusting the mixer before rebooting). If you 
experience this issue, the way to fix it is to open a terminal window, and 
issue the following command (as root).


/sbin/MAKEDEV -d /etc/udev/devices/ sound

----- Original Message ----- 
From: "Phill Edwards" <philledwards at gmail.com>
To: "MythTV Users List" <mythtv-users at mythtv.org>
Sent: Friday, July 22, 2005 3:13 AM
Subject: [mythtv-users] Re: [ATrpms-users] mixer always muted in FC4 withnew 
alsa packages

> Hi, after adding ATRPMS to my yum configuration, and doing yum
> update, the Gnome Mixer is always muted on boot.
> I assume this has to do with new alsa packages from ATRPMS.
> I'm running FC4 on a Dell Latitude D800 (Intel 8x0m sound card).
> I've tried running
> alsactl store 0
> as root
> everything was fine before installing the ATRPMS packages.

Yes - this seems to happen on upgrades, I've found. What I do is use a
mixer to get sound working and then save the asound.state file to
something like /etc/asound.state.good using alsactl.

Then I have this line in /etc/rc.local:
/usr/sbin/alsactl -f /etc/asound.state.good restore

Haven't had any problems since I started doing this other than one
version of an alsa upgrade didn't like the format of the saved file so
I had to save it again.

mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list