[mythtv-users] venetian blind picture

Chad masterclc at gmail.com
Tue Jul 19 03:15:05 EDT 2005

On 7/18/05, Greg Woods <greg at gregandeva.net> wrote:
> On Sun, 2005-07-17 at 20:14 -0600, Chad wrote:
> > The settings I was referring to are the ones you 'guessed'.  If those
> > aren't working, maybe there is something in the backend logs that tell
> > why.  Also, you could start the frontend from an xterm to see if it
> > provides any feedback on reasons it's not working.
> As far as mythtv is able to tell, it is working. Recordings get made and
> stored, they can be seen in the "Manage" section, it's just that the
> parameters for the recording are incorrect so what gets saved is
> garbage. I don't see any error messages at all in the backend logs or
> when running mythtv in a terminal window, but it may be that I just
> don't know what to look for.
> At the moment, I'm ready to just give up on this. I don't really want
> to, given the amount of time and effort I've already put into it, but it
> appears to require more technical knowledge about TV signals and video
> formats than I have, which leaves me guessing at what boxes should be
> checked and what values should be set for things. It also seems unlikely
> that anyone else would be able to diagnose my problem for me unless they
> had access to my system and could run Utilities/Setup for themselves, so
> I think I have hit a dead end. Maybe someday when I have time to learn
> all about TV signals and video formats and have some clue what I am
> doing, I could try again.
> What is *really* frustrating is that it was working at one time.
> >  And in the end, if
> > it is indeed working, maybe it's not interlacing, and it just reads
> > like that is the problem.
> I don't know if this helps, but I tried running mplayer with "-vf
> scale:-1:1" which is supposed to turn on interlacing. That changes what
> the picture looks like, but if anything it's worse. Looks more like
> interlacing is already on when recording but needs to not be on. Given
> that xawtv works, that seems likely, but again, I lack the knowledge of
> TV signal types and video formats to really know, so I'm just guessing
> again.
> I also don't know if this will help either, but another problem I now
> have that I didn't previously have is that I cannot change channels
> while watching live TV. It will show me whatever the last channel was
> that I had tuned to with xawtv, and it looks fine, but the up and down
> arrows have no effect. I wouldn't think this is related except that it's
> also a new problem I didn't used to have. I didn't notice it until now
> because I haven't been using Myth to watch live TV since xawtv is easier
> for me to use for that purpose.
> >
> > I get 1 station that gives me something like you are describing, and
> > for me, it's from a crap signal.
> In my case I think I can pretty well rule out problems with the card or
> the cable signal, because xawtv works and I have tried recording off
> several different channels. Also all this USED to work, so it almost has
> to be something in the recording settings that is wrong.
> It all started when I was having trouble trying to burn DVD's because
> my .nuv files were in the wrong format (MPEG-2 vs. MPEG-4), so I started
> tweaking settings trying to get things to come out in a different format
> and somehow screwed things up. But even a complete rerun of
> mythtv-setup, removing all of the settings and starting over from
> scratch, has not fixed the problem or caused any other problems, it's
> the same old same old no matter what I try. Transcoding works in that it
> runs, and the file size shrinks appreciably, but it doesn't correct the
> venetian blind picture problem. I don't think I'll try anything more as
> long as I am still just guessing.
> > If you can, grab a cheapie bt8x capture card (they are like 20 bucks
> > online) and see if the problem goes away.
> This is unlikely to help either (except that I might be using a
> different driver and therefore different settings). It also doesn't
> explain why things USED to work with the card I now have. I shouldn't
> have to do this, it feels like throwing good money after bad.
> > It's not a great plan, but
> > it'll give you second card anyway so you can toy with and use the HDTV
> > card for what it was intended ;)
> Not a bad idea in the longer term, but I have to convince myself that I
> can even make this setup work at all first. For it to be really useful,
> I am going to need a front-end machine in the main TV room, and that is
> too much money to lay out until I'm convinced this can work with me at
> the controls. I would also need an antenna to get OTA HDTV signals. I
> live in Colorado, near the eastern face of the mountains, so reception
> really sucks here; ghost signals bouncing off the mountains are a big
> problem. An antenna for me is going to mean a high quality rooftop
> model, rabbit ears do not work here, so that is a signficant investment
> as well. It might be worth it, but more likely, I would have to go to
> digital cable to get the HDTV shows I really want (mostly sports). This
> again displays my ignorance of how this all works, because what I have
> read on this list since I started suggests that the only way I can
> really get HDTV from digital cable is to use a firewire link from the
> cable box rather than using a capture card at all.
> >  And it will also give you the
> > ability to rule things out, like channel signal problems (assuming
> > it's also a local broadcast channel).
> All I have right now is analog cable. I have tried recording from
> several different channels and they all have the same problem, but the
> ultimate source of the content probably doesn't matter that much, the
> delivery method is analog cable in all cases.
> > You noted xawtv works fine, and said you may have dorked something up
> > in the recording profiles.  I'd play around with those settings,
> > switch between RTJpeg and Mpeg-4 and adjust the quality settings
> I think the solution lies here somewhere, but I spent a whole day
> Saturday doing just this without success, so my frustration quotient is
> exceeded for now. Unless I have something better to do than guess, it
> will probably be a while before I come back to this.
> > A re-install probably won't help, but maybe a backup and re-do of the
> > database might.
> I have already tried rerunning mythfilldatabase after re-running
> mythtvsetup and saying "yes" to remove settings when asked, but I think
> you mean something more than that.
> >  It may be a bit time intensive to import back in your
> > existing recordings after you get the database reconfigured
> I don't have too many of them right now, so if I knew HOW to re-import
> something, I could probably handle this.
> --Greg
> _______________________________________________

Wow, I'm sorry to hear life (regarding Myth) is suckin right now.  I
can defintely say I feel for ya when you say it feels like you need to
have a PhD in physics to actually get this thing rolling, with all the
ATSC, NTSC, SD, HD, UHF/VHF, bitrate, mp2/mp4...  It's sure a lot to
swallow.  Some of it I take at face value and just tuck it away, other
bits I research and learn, but still, I feel like I haven't gained a
great deal of knowledge in the areas that it would seem would really
help me to get this thing rolling perfectly (well, it actually IS
working perfectly for me right now, but I blame that on pure luck more
than anything else).

Anyway, I'd really like to stick with this for a bit longer to see if
we can't get SOMETHING figured out, even if it ends up being that we
figure out we know even less than we thought, we won't have given up
at this point.

A few things that may give us some headroom:

Check your mythtv-setup settings.  In your video sources section,
check that you have the channel frequency table correct.  I believe
you can also set this in the General settings in mythtv-setup, so
check there as well.  For your analog cable, you probably want

Also, in the General tab, make sure your TV Format is correct (probably NTSC).

Now go ahead and start mythfrontend and flip down to the Setup button,
and then to TV Settings.  In here we will try a couple things, after
changing 1 thing, test your playback.  I suggest testing playback
using "LiveTV" instead of a recording, just to make sure it's not the
recordings fault ;)

Go into the Playback button screen and check that:
Deinterlace is UNchecked.  We will first check to see if that change
alters your video output.  Now go back out to the main screen and
"Watch TV".  I will assume (from this point forward basically) that
this didn't work.  If it did, stop here :D

Next, go back and check the box.  You probably should go back and
check the output, but I'd move onto the next section first.  Check the
box, and go to the next option and change it to bob (2x framerate).

Leave the filters section blank... For now.

Uncheck all 4 boxes below the filter box.  Aspect override should be
off.  Go through the screens until you see Hardware Decoder Settings. 
IF you don't have an Nvidia 440 MMX or better (or better is vague if
you don't know about video cards, but basically if you don't have an
nvidia at all, uncheck both boxes at this screen.  If you do have an
nvidia card, and it's newer than 1-2 years, you probably have at least
a 440 MMX or better) make sure that the Xvmc box is unchecked.

Now comes the tricky section that is far over my head.  The overscan
screen.  Feel free to play with settings here, I don't personally
change them, so I suggest to leave them alone.  BUT, if all else
fails, it might be something worth plugging away on.

Go ahead and click through to Finish.

If all of this fails, I'd jump back out and drop the database.  If
this is an "all-in-one" setup, meaning the backend/frontend and
database are all on the same machine.  If it is, then here's how you
can drop the database without sacrificing anything in the long run:

su -
to root, then:
Kill any mythbackend processes:

killall mythbackend (or however you normally do this if you "normally" do)

And then dump the db:

mysqldump mythconverg > mythdb.sql

Here I am assuming that you have used default names for databases et
al.  If not, you will hopefully remember what it's called here.

Now the database is still there, you have only made a backup copy.  So
we need to actually drop the db now.

If you aren't comfortable doing this, feel free to disregard my advice
at anytime.  Tinkering with db's can sometimes be a bit more of a let
down than it should be.  If you don't care at this point, then let's
move on.

Log into mysql (still as root):
mysql -u root -p

Supply the root password.  If you don't get in with that, you will
need to look at resetting the root password for your database. 
Hopefully, you are in, and at a mysql prompt:

mysql -u root -p
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 11392 to server version: 4.0.24

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.


Here we dump the db:
DROP database mythconverg;

The semi colon is necessary.

Now...  You will be to create this db when you run mythtv-setup (as
you were when you first installed mythtv).  This *should* give you a
clean db to start with, and see what is unveiled.

If this all fails, the backup we made above can be fed back into mysql with:
mysql mythconverg < mythdb.sql -u root -p

Again, supply the root password (hopefully we got past this point earlier).

And now all should be back to (ab)normal as it currently is.

Well, that's about all I can think of for now, I'm really surprised
someone else hasn't chimed in with the 1 liner that I'm obviously

Good Luck!

More information about the mythtv-users mailing list