[mythtv-users] [SOLVED] Preview images not generated for imported recordings

Louie Ilievski loudawg at comcast.net
Sun Jul 17 20:12:23 EDT 2005

On Saturday 16 July 2005 11:15 pm, Louie Ilievski wrote:
> Hi all.  A few days ago I started from scratch with a new machine and
> created my new myth box.  Before doing so I backed up most of my recordings
> using nuvexport.  They imported just fine on the new box by passing the sql
> statements generated by nuvexport into the new mysql.  My problem is that
> in the Watch Recordings page, all of the preview images show up as nothing
> but black.  In MythWeb, nothing shows up at all.  Is there something in the
> database or somewhere else that I can change to trigger the backend to
> generate these thumbnails again?  Note that any new recordings that this
> new machine has recorded have their preview images generated just fine. 
> Thanks for any help.
> ~Lou

Ok, well I've been playing with this for a while, and here is what I found 
out.  After browsing through the database, I noticed that the recordedprogram 
table does not contain any of my backed up shows, only the new ones that have 
recorded.  However, recorded and oldrecorded contain both my backed up shows 
as well as the newly recorded ones.

I found an old thread saying to rename the file, touch the original file name, 
delete it within the frontend, and then run myth.rebuilddatabase.pl.  I tried 
this, but it didn't seem to work.

Finally, right in the middle of writing this email (which originally was meant 
to say something like "any more ideas given this new info?"), I went back to 
the database once more and browsed through the tables to make sure what I was 
writing was accurate.  I happened to notice something.  In recorded, which 
contained old and new shows, there was the hostname field, and all of my 
backed up recordings had the hostname of my old machine in that field.  So, I 
just did:
UPDATE recorded SET hostname="new" WHERE hostname="old";

I restarted the backend, and it all worked!  I suppose that if I had restarted 
the backend after running myth.rebuilddatabase.pl, it might have also worked, 
since I see no difference in the tables before I deleted the touched file and 
after running the script, with one exception.  The hostname was updated for 
that one test recording that the perl script updated.

Anyway, there you have it.  I'm happy again  :-)

I hope this will help someone in the future.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20050717/a023d8e4/attachment.pgp

More information about the mythtv-users mailing list