[mythtv-users] No output from IRW

Eric Jensen soastuff at no-homers.org
Fri Jul 15 21:02:18 EDT 2005

Eric Jensen wrote:

>I have a Universal Remote Control MX-500 and am trying to get it to work
>with an Irman.  I hooked it up to a Windows box and get output just
>fine, so the irman does support the signal from my remote.  When I run
>lircd and then irw or irrecord I don't get any output though.  No
>errors, but also no output.  I only have one serial device and I made
>sure lircd was using the right one.  I tried loading lircd with
>parameters --driver=irman --device=/dev/ttyS0, but then as soon as I run
>irw it closes and lircd is no longer running.  I am pretty clueless when
>it comes to this stuff, does anybody have any ideas?
Just an update.  I changed my serial from 3F8/IRQ4 to 2F8/IRQ3 since we
couldn't even talk to our Cisco modem.  But on 2F8/IRQ3 we can, so I
tried the Irman again and this is the messages I get back from lircd
when running `lircd -n -d /dev/ttyS1`

could not open config file '/etc/lircd.conf'
No such file or directory
lircd(any) ready

Now I run irw and get the following from lircd:

accepted new client on /dev/lircd
could not get hardware features
this device driver does not support the new LIRC interface
major number of /dev/ttyS1 is 4
LIRC major number is 61
check if /dev/ttyS1 is a LIRC device
caught signal

If I try and specify a driver with --driver=irman I get:

accepted new client on /dev/lircd
could not open /dev/ttyS1
irman_init(): Input/output error
caught signal

I am running them both as root.  I've tested the port by talking to a
Cisco modem and I've tested the device on my Windows machine, so I don't
think I either are bad.  Any thoughts?


More information about the mythtv-users mailing list