[mythtv-users] Buttons not working

Phill Edwards philledwards at gmail.com
Thu Jul 14 21:24:51 EDT 2005

> When I run mythtv-setup and it displays the question asking if I want to
> erase my device config the yes/no buttons don't behave properly.  I can
> change the focus using the arrows on my keyboard but if I hit enter on
> either one nothing really happens.  The focus disappears but that's
> about it.  More pressing on the arrow keys shifts the focus again.  The
> only way I can get past the first question is to hit the Escape key.
> The same thing happens with the second question asking if the channel
> data should be erased - nothing but the Escape key actually does
> anything.  From that point on navigation through the setup utility works
> as expected with the keyboard.  The remote control doesn't do anything
> though.
> When I run mythfrontend I run into similar problems.  The remote control
> doesn't work but most/all navigation appears to work properly.  At the
> main menu when I hit Escape I'm prompted with another question if I want
> to exit mythtv.  Just like with mythtv-setup I can change the focus and
> hit Enter multiple times but nothing happens.  Hitting Escape this time
> dumps me back to the main menu.  The only way I've found to shut down
> mythfrontend is to kill the process...
> I don't see any error output from mythtv-setup or mythfrontend that
> would indicate any problems with lirc or anything else.
> Anybody have any ideas why I'm having so much trouble with buttons (both
> the yes/no messages in myth and the remote not working)?  Any help would
> be greatly appreciated!

You need to use Alt-Enter or Ctrl-Enter (can't remember which). This
is a QT issue which has been fixed in more recent versions.


More information about the mythtv-users mailing list