[mythtv-users] Buttons not working

Bruce Pennypacker bruce at pennypacker.org
Thu Jul 14 19:19:36 EDT 2005

Hi all,

First, my setup:

Fedora Core 3 (64-bit) running on an AMD Opteron w/ an HD-3000 card and 
Hauppauge WinTV PVR-250.  All latest Fedora updates installed.  Running 
a custom built kernel to ensure the HD-3000 DVB drivers are 
included.  Running mythtv-0.18.1 built from sources & lirc-0.7.1 using 
the Hauppauge I2C config.  My configure line for mythtv looks like this:

./configure  --enable-audio-alsa --disable-audio-oss -disable-audio-arts 
--disable-audio-jack --enable-dvb --enable-lirc --disable-joystick-menu 
--enable-ivtv -dvb-path=/usr/src/linux- --disable-firewire

When I first started building up this machine most everything seemed to 
be working fairly well.  Unfortunately I suffered a drive failure which 
resulted in my re-installing everything...

I have both tuner cards working properly on their own.  I can load the 
DVB drivers and use utilities like azap with the HD-3000. I can also use 
the lirc irw utility and get responses to button presses on the 
Hauppauge remote.

When I run mythtv-setup and it displays the question asking if I want to 
erase my device config the yes/no buttons don't behave properly.  I can 
change the focus using the arrows on my keyboard but if I hit enter on 
either one nothing really happens.  The focus disappears but that's 
about it.  More pressing on the arrow keys shifts the focus again.  The 
only way I can get past the first question is to hit the Escape key. 
The same thing happens with the second question asking if the channel 
data should be erased - nothing but the Escape key actually does 
anything.  From that point on navigation through the setup utility works 
as expected with the keyboard.  The remote control doesn't do anything 

When I run mythfrontend I run into similar problems.  The remote control 
doesn't work but most/all navigation appears to work properly.  At the 
main menu when I hit Escape I'm prompted with another question if I want 
to exit mythtv.  Just like with mythtv-setup I can change the focus and 
hit Enter multiple times but nothing happens.  Hitting Escape this time 
dumps me back to the main menu.  The only way I've found to shut down 
mythfrontend is to kill the process...

I don't see any error output from mythtv-setup or mythfrontend that 
would indicate any problems with lirc or anything else.

Anybody have any ideas why I'm having so much trouble with buttons (both 
the yes/no messages in myth and the remote not working)?  Any help would 
be greatly appreciated!



More information about the mythtv-users mailing list