[mythtv-users] [OT] ivtv troubles

Matthew Daubenspeck matt at oddprocess.org
Thu Jul 14 20:59:43 EDT 2005

I know this is a bit OT, but I have tried all of the other lists and
haven't had any luck solving the issue. I know mythtv-user's are always
glad to help :)

In short, I can't modprobe ivtv.

I have been having this problem with kernels starting with 2.6.11-x                                 
including the most recent 2.6.12 version. They are all gentoo kernels,                              
and I have also tried them with kernels directly from kernel.org with                               
the same result. Here is the error:                                                                 
# modprobe ivtv                                                                                     
WARNING: Error inserting i2c_core (/lib/modules/2.6.12-gentoo-r4/kernel/drivers/i2c/i2c-core.ko): Un
known symbol in module, or unknown parameter (see dmesg)                                            
WARNING: Error inserting i2c_algo_bit (/lib/modules/2.6.12-gentoo-r4/kernel/drivers/i2c/algos/i2c-al
go-bit.ko): Unknown symbol in module, or unknown parameter (see dmesg)                              
FATAL: Error inserting ivtv (/lib/modules/2.6.12-gentoo-r4/extra/ivtv.ko): Unknown symbol in module,
 or unknown parameter (see dmesg)                                                                   
Here is dmesg:                                                                                      
i2c_core: Unknown parameter `i2c_debug'                                                             
i2c_algo_bit: Unknown symbol i2c_del_adapter                                                        
i2c_algo_bit: Unknown symbol i2c_add_adapter                                                        
ivtv: Unknown symbol i2c_bit_add_bus                                                                
ivtv: Unknown symbol i2c_bit_del_bus                                                                
I don't think it's ivtv itself, as I have tried the stable (0.2.0_rc3)                              
as well as 0.3.6z and get the same error. I have checked and rechecked                              
my kernel configs for i2c and I believe everything is correct. I am                                 
using the same config with 2.6.10 and it works fine.                                                
Any suggestions? Thanks for your time.       
  Matthew Daubenspeck

20:58:25 up 6:43, 1 user, load average: 0.00, 0.00, 0.00

More information about the mythtv-users mailing list