[mythtv-users] Re: Plextor TV402U FPS NTSC

Eric Gilbert eric.gilbert at gmail.com
Wed Jul 13 14:26:01 EDT 2005

Ok I swear this is the last ... It was partially a settings problem
and partially a code assumption...

On 7/13/05, Eric Gilbert <eric.gilbert at gmail.com> wrote:
> Replying to my own post with additional info ..
> On 7/12/05, Eric Gilbert <eric.gilbert at gmail.com> wrote:
> > Hi All,
> >
> > I'm using the PX-TV402U with .18 (KnoppMyth) and can use it just fine
> > for Live TV, but all of the scheduled recordings the audio is out of
> > sync.  The size is set to 640x480 and the bitrate is set to 4000 in
> > the recording profiles (since this appears to be the maximum rate the
> > hardware supports for non mpeg) and all of the check boxes marked as
> > well as the audio set to 48khz and quality set to 9 to try and get the
> > best quality.
> >
> > When I run the recording through MPlayer it shows that the FPS is 25
> > (PAL) while last I checked NTSC was 29.97. And not suprisingly the
> > audio steadily drifts out of sync while watching.
> >
> > Is this a known issue resoled in .18.1
> >
> > I searched the archives (using plextor and tv402) and couldn't find
> > much, other than support was added in march.
> >
> > Do I need to tweak some settings or do I need to tweak some code?
> >
> > Thanks,
> > Eric
> >
> Also when I use gorecord with the following:
> gorecord -input 2 -tvchan ntsc-bcast:20 -duration 60 -format mpeg4
> -bitrate 4000 capture20.mp4
> MPlayer reports:
> VIDEO:  [DX50]  640x480  24bpp  29.970 fps  3693.0 kbps (450.8 kbyte/s)
> So I am pretty certain that I have a NTSC unit.
> But when Myth does a recording MPlayer reports:
> Detected MythTV stream, reading extended format information
> VIDEO:  [XVID] 640x480 25.00 fps
> I can't find any location to set the FPS and I'm manually made sure
> that my channels are set to NTSC.
> Any thoughts?
> Eric

It turns out after some more sharp stick poking, that my TVFormat for
the system is set to ATSC as default since I started off with only a
pcHD3K. The NuppelVideoRecorder.cpp looks to the System default
instead of the specifics for the channel for recording and in
RecorderBase.cpp it checkes for ntsc, ntsc-jp and pal-m and sets the
video_frame_rate = 29.97 .. which is great if the default TVFormat is
one of those, otherwise it assumes the format to be pal and sets the
video_frame_rate = 25.0.

So hopefully this comes in handy for someone else. If you have more
than one TVFormat you are recording in only the default will be used.
I doubt anyone else has run into this.


More information about the mythtv-users mailing list