[mythtv-users] mythweb error in program_listing.php

Johan Reinalda johan at global.thunderbird.edu
Wed Jul 6 19:17:34 EDT 2005

do I feel pretty stupid. Turn out in /mythweb/settings_mythweb.php, there is 
a checkbox for 'only display favorites'. Unchecking this fixed the issue.

However, this should probably be fixed in the code...


----- Original Message ----- 
From: "Johan Reinalda" <johan at global.thunderbird.edu>
To: <mythtv-users at mythtv.org>
Sent: Wednesday, July 06, 2005 4:06 PM
Subject: [mythtv-users] mythweb error in program_listing.php

> All,
> after I used mythweb to delete a channel, I now get the following error 
> when starting to browse at /mythweb/ :
> Fatal Error at /var/www/html/mythweb/includes/programs.php, line 107:
> load_all_program_data() attempted with an empty $Channels array
> I've gotten as far as figuring out that this is related to loading the 
> channel list in load_all_channels() in line 42 of program_listings.php. 
> This function is defined in channels.php, and is returning an empty set.
> What I don't understand is why this is happening. This function does one 
> of two things, either it loads  the I have list of favorite channels, or 
> all channels from the database. As I have never set favorites, this is 
> empty, but the second case should return a set.
> When I hit other pages directly (by typing the url in, eg 
> /mythweb/recording_schedules.php), this still works fine.
> Any suggestions on how to fix this?
> Thanks,
> Johan
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users 

More information about the mythtv-users mailing list