[mythtv-users] lirc not working in X using FC 3 and DVICO remote.irxevent does not exist!

Chris Henderson jchendo at gmail.com
Tue Jul 5 23:56:05 EDT 2005

> Thanks for the help - it worked!
> For the record: I'm now using latest version of lirc (version 0.7.1
> with built-in support for the DVICO remote - no patches required) and
> I downloaded Chris Pascoe's lircrc file
> (http://www.itee.uq.edu.au/~chrisp/Linux-DVB/DVICO/mythtv-lircrc) and
> copied it to /home/mythtv/.mythtv/lircrc (as you suggested). Jani's
> lircrc is configured for irxevent so this doesn't work.
> Now all I need to do is sort out some channel setup issues and I'm away!
> Thanks again for the help.
> Cheers

Just for the record, with a lot of help from another person on this
list we got the dvico remote working as well.

The native lirc that comes with standard mythtv distro supports the
dvico remote.

After a lot of stuff ing around it was as simple as adding the
following line to the rc.local startup file.

/usr/local/sbin/lircd --driver=dvico --device=/dev/hiddev0

just do 'locate lircd' and it will tell you where it is. (change path
to lircd if necessary)

then all you need is the lircd.conf file (tells the deamond what the
key presses are) and the lircrc file (tells myth what the outputs from
the deamon do)

Put them into the following dir's

there is no need to install lirc pre 074 or what ever. The dvico
remote works out of the box. So much so that i had a backend /frontend
setup in the study and the wife wanted it in the loung. So i built a
frontend  (E-vetrca) as per jarrods guide and then unplugged the
remote off the backend, plugged it into the front end, did what i said
above and it worked.

Just my 2 cents


More information about the mythtv-users mailing list