[mythtv-users] lirc not working in X using FC 3 and DVICO remote.irxevent does not exist!

Matthew Carle matthew_carle at hotmail.com
Mon Jul 4 07:30:37 EDT 2005

I had the same problem (well irxevent was missing anyway). I am also using
FC3 and the same remote.

I'm not really sure what I did to fix it. What I do know is that I am using
the latest lirc without patches. I'm not sure that you actually need
irxevent if you are using native lirc support in mythtv (I'm probably wrong
- someone can verify). Just move the lircrc file to
/home/mythtv/.mythtv/lircrc (or adjust for your config) and try running
mythfrontend from a shell window - it will output an error if it can't find
the lircrc file.

Good luck,


> -----Original Message-----
> From: mythtv-users-bounces at mythtv.org 
> [mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Dario Mratovich
> Sent: Monday, 4 July 2005 4:44 PM
> To: mythtv-users at mythtv.org
> Subject: [mythtv-users] lirc not working in X using FC 3 and 
> DVICO remote.irxevent does not exist!
> Hi
> I'm new to Linux and Myth and have been ploughing my way 
> through Jarod and Jani's guides to get Myth installed and 
> running. I'm nearly there:
> Myth runs OK but I can't get my DVICO remote working in Myth.
> I'm using Fedora Core 3 and have a DVICO Fusion HDTV card and remote.
> I've mainly followed Jani's guide to get to where I am now, 
> although I hit a few bumps on section 8 "Making the remote work"
> (http://www.users.on.net/~jani/dvico-mythtv-8.html).
> I've got the lirc-0.7.0pre4.tar.bz2 source and applied Chris 
> Pascoe's patch (as per the guide). I've configured and 
> compiled lirc and kicked off lircd. I can run irw and I get 
> feedback from pressing remote buttons. So far so good. The 
> problem is that irxevent does not seem to build.
> I've tried Jani's steps carefully several times to no avail. 
> I've also tried downloading lirc-0.7.0 and applying Chris 
> Pascoe's patch for 0.7.0 which just yields the same result - 
> irw works fine, but irxevent isn't created.
> When I run setup.sh to configure lirc before compiling, I 
> notice "checking for X... no" in the output - does this mean 
> that it hasn't found my X11 libraries and therefore won't 
> compile the lirc X tools (i.e. irxevent)?
> I've tried Googling and saw a post that had similar symptoms
> (http://sourceforge.net/mailarchive/message.php?msg_id=11923869)
> although with a later version of lirc. The author of the post 
> followed up with another post
> (http://sourceforge.net/mailarchive/message.php?msg_id=11924405)
> saying that he solved the problem by pointing the compiler to 
> the correct location of the X11 libraries on his FC3 system.
> Bingo (or so I thought). I tried following his advice, but my 
> /usr/X11R6/lib/ path contains
> /usr/X11R6/lib/libX11.so.6
> /usr/X11R6/lib/libX11.so.6.2
> but not /usr/X11R6/lib/libX11.so. I then tried creating the 
> symlink like this:
> ln -s /usr/X11R6/lib/libX11.so.6 /usr/local/lib/libX11.so
> and re-configuring and recompiling lirc, but that didn't seem to work.
> I've also tried lirc-0.7.1 which has built-in support for the 
> DVICO remote (so I don't have to apply any patches) but I 
> have the same result.
> So is the problem that the compiler can't find my X11 libraries?
> Surely these must exist if I'm able to run X, right?
> Thinking that maybe they're not installed correctly, I tried 
> to use the Add/Remove packages GUI tool in KDE to install X 
> Windows Developer Tools. When I tried to install any of them, 
> I got an error saying that the the packages I wanted to 
> install require xorg-x11-libs and xorg-x11--xfs to be 
> installed before I can continue.
> Seeing no way to install these I then tried "apt-get install 
> xorg-x11-libs" but I got a message saying that they're 
> already installed... What's going on?!
> I'm really stuck here and I don't know what to do. I would 
> really appreciate any help you can give me. I'm still new to 
> this Linux thing so be gentle if I've missed the obvious  :-)
> Cheers
> Dario
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list