[mythtv-users] nuvexport: Ok here Bad over there?

Jarod Wilson jarod at wilsonet.com
Fri Dec 30 20:35:43 EST 2005

On Friday 30 December 2005 17:13, John Andersen wrote:
> On 12/30/05, Jarod Wilson <jarod at wilsonet.com> wrote:
> > Another possibly-relevant data point... I recently transcoded a bunch of
> > shows off a network mount using ffmpeg (via myth2ipod) on an smp machine,
> > each using only one cpu, and the resulting transcodes are flawless.
> Was that with real cpus or hyperthreaded ones


> and how did you 
> know each only used one CPU?

Run only one transcode at a time, watch top output. I guess more accurately, 
each job used only 1 thread, i.e., the machine was never more than 50% busy 
w/a single transcode. After seeing that, I actually set up two transcode 
queues of about 35 shows each, then turned both loose at the same time, 
pegging the cpus for like two or three days. Good cpu burn-in test with 
productive results... :)

> Did you bind the jobs to a particular CPU?


> In my setup, any transcode job will busy up both CPUs and
> and attempts to bind to a single cpu seems to have no
> effect.

Does the ffmpeg '-threads 1' option help?

Jarod Wilson
jarod at wilsonet.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20051230/ee4bc9c8/attachment.pgp

More information about the mythtv-users mailing list