[mythtv-users] New PVR-150, apt-get problems from atrpms

Chris Hoff hoffchris at gmail.com
Fri Dec 30 12:17:16 EST 2005

I got a PVR-150 for Christmas and I'm looking to install it alongside
my PVR-250.  My MythTV system is FC3 and was built about a year ago. 
I haven't really updated anything other than Myth since I got it
working.  I knew I would have to update the ivtv drivers at the very
least, so I decided to do a dist-upgrade before installing the card
and make sure everything is still working.  It needed to download a
bunch of packages, so I let it run overnight.  This morning, it was
stuck about halfway through installing the packages.  The system
wasn't locked, apt-get just wasn't responding.  After giving it a long
time, I killed apt-get and tried to rerun dist-upgrade.  Now I am
getting conflicts:

# apt-get update
Get:1 http://dl.atrpms.net fc3-i386/atrpms release [890B]
Get:2 http://ayo.freshrpms.net fedora/linux/3/i386 release [2137B]
Get:3 http://dl.atrpms.net fc3-i386/redhat release [1183B]
Fetched 4210B in 1s (2910B/s)
Hit http://ayo.freshrpms.net fedora/linux/3/i386/core pkglist
Hit http://ayo.freshrpms.net fedora/linux/3/i386/core release
Hit http://ayo.freshrpms.net fedora/linux/3/i386/updates pkglist
Hit http://ayo.freshrpms.net fedora/linux/3/i386/updates release
Hit http://ayo.freshrpms.net fedora/linux/3/i386/freshrpms pkglist
Hit http://ayo.freshrpms.net fedora/linux/3/i386/freshrpms release
Hit http://dl.atrpms.net fc3-i386/atrpms/stable pkglist
Hit http://dl.atrpms.net fc3-i386/atrpms/stable release
Hit http://dl.atrpms.net fc3-i386/redhat/release pkglist
Hit http://dl.atrpms.net fc3-i386/redhat/release release
Hit http://dl.atrpms.net fc3-i386/redhat/updates pkglist
Hit http://dl.atrpms.net fc3-i386/redhat/updates release
Reading Package Lists... Done
Building Dependency Tree... Done

# apt-get dist-upgrade -V
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
  glibc-common#2.3.3-74: Conflicts: glibc (> 2.3.3)
  glibc-common#2.3.6-0.fc3.1: Conflicts: glibc (< 2.3.6)
  libid3tag#0.15.1b-3.1.fc3.fr: Conflicts: libmad (< 0.15.1b)
  libtool-ltdl: Obsoletes: libtool-libs
E: Unmet dependencies. Try using --fix-broken.

At this point, I tried --fix-broken but it gave me a long list of
packages that would be removed including some "essential" packages as
it called them.  It said I should only proceed if I really know what
I'm doing, which I don't, so I didn't.

Any ideas?
I can provide the output of # apt-get --fix-broken install -V if it
would be helpful.


More information about the mythtv-users mailing list