[mythtv-users] Commonly seen bug with undocumented solution!

roger roger at eskimo.com
Thu Dec 22 03:04:20 EST 2005

Found it!  After looking over logs extensively of mythfrontend &
mythbackend (with --verbose all and using gdb & strace).  All provided
errors such as buffer errors and video errors were entirely unuseful in
detecting this bug.

I went into mythsetup and chose, "Capture Cards" > "(/dev/v4l/video0)"
device" > default input = "television".

I barely noticed but previously "default input" was set to a value of
"Television" and not "television"!  All other channels were started with
a lower case letter (ie. s-video, composite, and radio).  So I changed
the value to "television" and Live TV finally worked!

When I returned to the same menu applet within mythsetup, "Television"
default input setting no longer existed.  All were lower case letters.

(wow.  ~2 mos of recompiling and other things and it was this!)

On Sat, 2005-12-17 at 13:42 -0800, roger at eskimo.com wrote:
> I've encountered this bug numerous times and sometimes it was solved
> erratically, by either recompiling glibc with -O3 ops, or other unknown
> reasons. 
> I've also done quite a bit of searching in the past month or two and
> seem to have found that this bug is caused by an audio issue while using
> the
> Live TV playback.
> Hardware: Hauppauge WinTV PVR2 (using pvrusb2 driver
> http://www.isely.net/pvrusb2.html).  The device streams a mpeg2 stream
> on /dev/v4l/video0 and is very stable.  Mike also is extremely
> aggressive with both the development and maintaining of the pvrusb2
> driver.  I can easily do:
> $ cat /dev/v4l/video0 > test.mpg | mplayer test.mpg (test.mpg being a
> fifo file.)
> Yet, mythtv has issues with playback of this stream using the Live TV
> profile.  I'm seeing this issue on both, my server and laptop.  Both
> using nvidia cards.  And I've recompiled mythtv with & without nvidia
> and opengl options including currently debug (-g).  I've also recompiled
> libmpeg2 along with 3-4 different versions of nvidia drivers.  I've also
> toggled all sound options within mythtv settings.

Key fingerprint = 8977 A252 2623 F567 70CD 1261 640F C963 1005 1D61

Thu Dec 22 00:00:32 PST 2005

More information about the mythtv-users mailing list