[mythtv-users] r5a22: 5.1 spdif Divx sound with mplayer - how ?

Warpme warpme at o2.pl
Sat Dec 24 15:29:00 EST 2005

Hi *

Maybe somebody help me with following issue:

I have DIVX file with 5.1 sound, and I want to play it via MPLAYER.

My MythTV (R5A22) system is connected via digital SPDIF connection to my 
Home theater aplituner.

Launching mplayer with following parameters:

#mplayer -channels 6 -ac hwac3,a52, "ACDC - Stiff Upper Lip.avi"

gives only 2.0 sound.
Here below is output from console:

Setting up LIRC support...
mplayer: could not open config files /root/.lircrc and /etc/lircrc
mplayer: No such file or directory
Failed to read LIRC config file ~/.lircrc.
You will not be able to use your remote control.
Playing ACDC - Stiff Upper Lip.avi.
AVI file format detected.
VIDEO:  [DX50]  640x352  24bpp  25.000 fps  1134.4 kbps (138.5 kbyte/s)
Forced audio codec: hwac3
Opening audio decoder: [hwac3] AC3/DTS pass-through SP/DIF
No accelerated IMDCT transform found
hwac3: switched to AC3, 448000 bps, 48000 Hz
AUDIO: 48000 Hz, 2 ch, 16 bit (0x400), ratio: 56000->192000 (448.0 kbit)
Selected audio codec: [hwac3] afm:hwac3 (AC3 through SPDIF)

It seems like I have "AC3/DTS pass-through SP/DIF", but why there is 
"AUDIO: 48000 Hz, 2 ch, 16 bit (0x400), ratio: 56000->192000 (448.0 kbit)" ?

This file in XINE plays nicely 6-ch sound, so probably it isn't problem 
of audiostream.

How can I overcome this problem ?

milion thanx in advance

More information about the mythtv-users mailing list