[mythtv-users] Re: FC-4 installation - Are these dead symlinks wrong?

Nick knowledgejunkie at gmail.com
Sun Dec 18 16:30:54 EST 2005

On 18/12/05, Don <dlbrett at zoominternet.net> wrote:
>  On the other distro thing, anything is possible, but the box has been built
> from scratch.  I may have grabbed something from an alien location, but I
> don't remember doing it.
>  On deleting the broken symlinks, I assumed you meant both the K... and S...
> symlinks for lirc.  I got rid of all the lirc symlinks on /etc/rc0.d
> through  /etc/rc6.d (both K... and S... on each).  Then I ran:
>  /sbin/chkconfig --add lircd
>  This gave me the K... simlinks on all the rc*.d directories (0 - 6)
>  And....
>  # /sbin/chkconfig lircd --list
>  lircd           0:off   1:off   2:off   3:off   4:off   5:off   6:off
>  So I ran:
>  /sbin/chkconfig lircd on
>  And now I have:
>  [root at sanson rc2.d]# /sbin/chkconfig lircd --list
>  lircd           0:off   1:off   2:on    3:on    4:on    5:on    6:off
>  So now I have:
>  K10lircd    on rc0.d, rc1.d, and rc6.d
>  S90lircd    on rc2.d, rc3.d, rc4.d, and rc5.d
>  Which, I guess looks correct, but after reboot, it still does the same
> thing.   So...., what causes this:
>  # /sbin/service lircd status
>  lircd dead but subsys locked
>  ????

Possible that the init script is trying to start lircd using a device
that doesn't exist (trying to use /dev/lirc0 when /dec/lirc exists or
vice versa). You could create a symlink between these two device
names, and check the init script to see which device it is trying to

I had the 'lircd dead...' error early on, and this was the cause (FC2)

As FC4 uses udev for device creation/deletion, it is also possible to
amend the udev rule for lirc to ensure the device created is correctly
named for the script.


More information about the mythtv-users mailing list