[mythtv-users] FC-4 installation - Are these dead symlinks wrong?

Nick knowledgejunkie at gmail.com
Sat Dec 17 20:36:47 EST 2005

On 17/12/05, Don <dlbrett at zoominternet.net> wrote:
>  I'm working on getting the remote control to work on my FC-4 installation
> (Jarods guide, very nice).  I don't think lircd is starting properly.  Could
> this be the reason?
>  # /sbin/chkconfig --list | grep lirc
>  lircd           0:off   1:off   2:on    3:on    4:on    5:on    6:off
>  Using "ls -color" to check each of the rc*.d directories I get this on each
> of the "on" directories.  Each is highlighted in red, which /etc/DIR_COLORS
> defines as a dead symlink.
>  lrwxrwxrwx  1 root 14 Dec 11 18:37 K71lirc -> ../init.d/lirc
>  And, /etc/init.d/ does not have a lirc file, but it does have a lircd file.
>  Should the symlink be pointing to /etc/init.d/lircd instead?  If so, how do
> I correct it?  Thanks,

If you don't have any entries in your /etc/rc2.d through /etc/rc5.d
directories with links to /etc/init.d/lircd then yes. What do you get
if you run:

/sbin/service lircd status

As chkconfig states that the lircd service is 'on' in runlevels 2-5,
there should be symlinks in these directories, starting with 'S' to
denote the service is to start in the particular runlevel (a 'K'
symlink states the service should be killed).

To fix the problem (i.e. if the lircd symlinks are _not_ present in
your runlevel directories) and you _do_ have a /etc/init.d/lircd file,
you can run:

chkconfig --level 2345 lircd on

This should create the appropriate symlinks to ensure lircd starts in
the appropriate runlevels.


More information about the mythtv-users mailing list