[mythtv-users] Some questions regarding ATI Radeon drivers and overscanning

Ole Andre Schistad oschista at chello.no
Sat Dec 17 07:06:41 EST 2005

Hello all, first post to the mailing list but a user of 6 months.

I have a working mythtv system that I recently acquired a cheap 
powercolor radeon 9250 card for. The TVout is amazingly clear, using an 
SVHS to SCART cable, but the overscan (or lack thereof) leaves something 
to be desired.

First of all, there seems to be a bug in many of ATIs driver releases 
that totally prevents the card from overscanning at all - the 
fireglcontrolpanel application has no effect whatsoever on the screen 
size. This applies (as far as I've seen) to all releases since 8.16 of 
their xorg driver. Wether it also applies to the regular XFree86 package 
is unknown.

Secondly, even in those driver releases where the fireglcontrolpanel can 
modify the image, the Xserver is ignoring the settings in the config 
when it loads. Only after I fire up the control panel application does 
the screen adjust to the preset overscan values - which clearly is not 
how things ought to work

Since I refuse to believe that this is how it's supposed to be, I'm 
hoping for some feedback from other ATI users on the list who 
(hopefully) have a working setup.

My own system runs on the following config;

Gentoo 2005.1
Xorg 6.8.2-r2
Framebuffer in kernel, using standard vga driver
kernelversjon 2.6.12-6 (gentoo-sources)
Motherboard: EPoX 8HMMI-A (VIA K8M800 chipset, mATX formfactor)

ATI drivers tested: 8.8.25, 8.14.13, 8.16.20, 8.18.8 & 8.20.8

It would be very helful if you could please post your own config if you 
are able to adjust overscan and have it stick.


Ole André Schistad

More information about the mythtv-users mailing list