[mythtv-users] DCT-6200 Firewire issue User Database

David Rudder drig at noses.org
Mon Dec 12 17:15:23 EST 2005

Thanks Steve, for this and the rest of your help!

Steve Adeff wrote:

>I'm trying to figure out the issue with this firewire thing. My laptop is 
>perfectly accurate when changing channels but my mythbox isn't. theres a 
>couple differences between the two though. Since this comes up so much as a 
>problem for people I want to start collecting information on the issue to see 
>if I can find out where the problem is.
>Could anyone that is using firewire to control a Motorola DCT-6xxx series 
>cable box respond to me off list with the following info:
>1. firewire chipset being used (lspci|grep FireWire)
[root at mythtv proc]# lspci|grep FireWire
00:0b.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host 
Controller (rev 80)

>2. your plugreport output for the Node connected to the DCT.
[root at mythtv proc]# plugreport
Host Adapter 0
Node 0 GUID 0x00152ffffed1547e
oMPR n_plugs=1, data_rate=2, bcast_channel=63
oPCR[0] online=1, bcast_connection=0, n_p2p_connections=0
        channel=0, data_rate=2, overhead_id=0, payload=376
iMPR n_plugs=0, data_rate=2
Node 1 GUID 0x0011d800003491ed
libiec61883 error: error reading oMPR
libiec61883 error: error reading iMPR

>3. the output from a 6200ch -v channel change
[root at mythtv contrib]# ./6200ch -v 120
node 0: vendor_id = 0x0000152f model_id = 0x000064cb
AV/C Command: 120 = Op1=0x00487C21 Op2=0x00487C22 Op3=0x00487C20
(I had to change some vendor and model ID numbers in the 6200ch source)

>4. Your Kernel (uname -r)
[root at mythtv contrib]# uname -r

>5. Your 'modinfo raw1394' output
[root at mythtv proc]# modinfo raw1394
license:        GPL
vermagic:       2.6.14-1.1644_FC4 686 REGPARM 4KSTACKS gcc-4.0
depends:        ieee1394
alias:          ieee1394:ven*mo*sp0000A02Dver00010001*
alias:          ieee1394:ven*mo*sp0000A02Dver00000100*
alias:          ieee1394:ven*mo*sp0000A02Dver00000101*
alias:          ieee1394:ven*mo*sp0000A02Dver00000102*
srcversion:     9435F3B41F2674B91625E97

>6. your accuracy rate (0 - 5, 5=perfect channel changes, 0=numbers get 
>detected but rarely does it work).
5 - The channel change always works, I think. Since so many recordings 
are messed up, it's possible the channel changes are not working 
perfectly and I don't notice.

>7. a brief description of what your box does when you try and change channels. 
>I have a brief description of what happens to me below in the quoted email.
This is with a DCT-6412.

The channel change always works, but video input only works sporadically 
(25-33% of the time).  I can reproduce this with test-mpeg2, so it's not 
a mythtv thing.  Steve Adeff has given me some good help, and I'm 
looking at swapping my DCT-6412 for a normal DCT-6200.  The more I play 
with this box, the more truly broken is seems.


>Hopefully we can figure this out and end the problem.

More information about the mythtv-users mailing list