[mythtv-users] DCT-6200 Firewire issue

Steve Adeff adeffs at gmail.com
Mon Dec 12 13:12:58 EST 2005

On Monday 12 December 2005 10:50, Frank Lynch wrote:
> On 11/30/05, Steve Adeff <adeffs at gmail.com> wrote:
> > I wrote a script that would change the channel +1 run test-mpeg and if
> > data was received write the channel and "ok" in a text file. This was so
> > I could quickly figure out what channels were 5C'd for me, through the
> > whole script I didn't run into a channel change error. I then played
> > around with it (in awe that it actually worked of course) and again had
> > no issues. all through p2p.
> Hi Steve,
> Would you mind sharing your script with the list?
> I'm in the process of setting up a firewire connection to my cable
> box, and your script could save me quite a bit of time (as opposed to
> going through and manually finding out which channels are 5C'd).
> thanks,
> --Frank

i would, but I think I deleted it (ie. I can't find it...).

whats funny is that now that I have a permanent Myth setup with my cable box 
using 6200ch to tune the channels I've noticed a lot of mis-changes.

I'm sitting here ssh'd in to the machine running 6200ch over and over trying 
different channels (this box is p2p only which may be of issue?) and am 
getting qute a few mis-controled channel changes.

it looks like whats happening is the box thinks it receives doubles of some 
numbers. This will either cause the box to think its receiving 4 or 5 
ie. tell it to tune to 256 and when it errors I get:
255   <- no 6 even gets sent!
2556 = ch 6 gets tuned
25566 = ch 66 gets tuned.

so far its usually the middle # that gets repeated but I've had the third 
number repeated occasionally.

Which leads me to think that perhaps its something wrong with 
libavc1394/libraw1394 or the 6200ch program.


More information about the mythtv-users mailing list