[mythtv-users] PVR-250 setup

Mark Knecht markknecht at gmail.com
Mon Dec 12 09:01:23 EST 2005

On 12/12/05, mythtv at jehster.net <mythtv at jehster.net> wrote:
> Mark Knecht wrote:
> > I have had this problem periodally, off and on, for over a year. I've
> > reported it here and never found a solution. One thing I ran into when
> > I got it working the last time was that I had been installing the ivtv
> > driver by hand and that installation only installs to /usr/local and
> > does not have a make uninstall switch. When I switched and started
> > using portage ivtv got installed in /usr and the two versions were
> > fighting with each other. I cleaned things up by hand, reinstalled
> > from portage again and seem to have been alright.
> >
> > This problem is not PVR-250 specific. I have a PVR-150 and PVR-250 in
> > the same system. The 150 is card #1 and it had this problem also.
> Thanks for your reply Mark. FWIW, I installed the ivtv package from
> portage and am experiencing this.
> Something else to make note of here (likely having nothing to do with this
> issue). When I upgraded to gcc 3.4.4, Myth could no longer see *any* of my
> inputs. The ivtv module loaded fine, and 'ivtvctl -a' output looked
> normal. But Myth couldn't seem to recognize it. I re-emerged ivtv and Myth
> as well as recompiled my kernel with the new gcc, but nothing worked. And
> revdep-rebuild didn't catch it either. I still don't know what went wrong,
> but whatever it was, 'emerge -e world' fixed it.
> Thanks for the input.
> Roy

   Sorry for not remembering this earlier. What I also did to get
around the problem on one of my backend servers with only a PVR-150
was to delete the card in mythtv-setup and then rebuild it from
scratch. Someone suggested that the ivtv developers had changed some
of the internal naming in the driver and somehow Myth wasn't picking
this up correctly. Try it. I hope it might help you.

1) Run mythtv-setup
2) Delete card settings when you enter
3) Leave channel settings alone
4) Rebuild the card definition, choosing /dev/v4l/video0
5) Make sure the card is linked up with Tuner0 in the Input Connections section

(I cannot explain why I use /dev/v4l/video0 in this definition but
test from the command line using /dev/video0. Anyone care to explain
that to me?)

   Note that you should make sure you can capture a few seconds of
video at the command line:

cat /dev/video0 > test.mpg

and that you can watch it successfully in mplayer

mplayer test.mpg

just to ensure it's not an ivtv problem.

Hope this helps,

More information about the mythtv-users mailing list