[mythtv-users] TiVo remote on KnoppMyth

Rick Strobel rstrobel at infotime.com
Sat Dec 10 23:44:36 EST 2005

OK, some success.  Here's the first stage of what I tried, but which I think
was made irrelevant by the second stage.  I followed this readme:
[quote]LIRC kernel modules source for DEBIAN

In the Debian packaging of LIRC, kernel module sources are installed in
/usr/src/lirc-modules.tar.gz. In order to build them, you should:

        cd /usr/src
        tar -xzf lirc-modules.tar.gz

You will now have a directory called lirc under /usr/src/modules, please
/usr/src/modules/lirc/README for further instructions.
root at mythtv:/usr/share/doc/lirc-modules-source#[/quote]When I tried the
"further instructions" I got lost and gave up.

The next thing I tried (which worked) was recompiling LIRC based on this
Knoppmyth wiki article:

When I tried to start lircd did I was told it couldn't find lircd.conf in
/etc so I copied it there.  The lircd.conf file was originally called TIVO
and I'm pretty sure it's the right one for my remote.  My remote is for a
Series 1 TiVo.

ONE PROBLEM - only the Play and Pause buttons work.  The replay button
starts the video at the beginning instead of jumping back 8 seconds like it
does on a TiVo, but I guess that's for another thread.  None of the other
buttons on the remote seem to have any effect

Here's the text of that file:
[code]root at mythtv:/usr/local/sbin# cat lircd.conf
# This config file has been automatically converted from a device file
# found in the 06/26/00 release of the Windows Slink-e software
# package.
# Many thanks to Colby Boles of Nirvis Systems Inc. for allowing us to
# use these files.
# The original filename was: "tivo.cde"
# The original description for this device was:
# tivo tx file

begin remote

  name  TIVO
  bits           32
  flags SPACE_ENC
  eps            20
  aeps          200

  header       9000  4500
  one           562   562
  zero          562  1687
  ptrail        562
  repeat       9000  2250
  gap          46000
  toggle_bit      0

  frequency    40000

      begin codes
          TIVO                     0x000000005EF3FFF0
          LIVETV                   0x000000005EF377F8
          UP                       0x000000005EF3D7F8
          DOWN                     0x000000005EF397F8
          RIGHT                    0x000000005EF357F8
          LEFT                     0x000000005EF317F8
          THUMBSDOWN               0x000000005EF3E7F8
          THUMBSUP                 0x000000005EF3A7F8
          SELECT                   0x000000005EF367F8
          RECORD                   0x000000005EF3FBF4
          PLAY                     0x000000005EF37BF4
          CH+                      0x000000005EF387F8
          CH-                      0x000000005EF307F8
          REV                      0x000000005EF3BBF4
          FWD                      0x000000005EF3DBF4
          PAUSE                    0x000000005EF33BF4
          SLOW                     0x000000005EF35BF4
          REPLAY                   0x000000005EF39BF4
          JUMPTOEND                0x000000005EF31BF4
          1                        0x000000005EF3EBF4
          2                        0x000000005EF36BF4
          3                        0x000000005EF3ABF4
          4                        0x000000005EF32BF4
          5                        0x000000005EF3CBF4
          6                        0x000000005EF34BF4
          7                        0x000000005EF38BF4
          8                        0x000000005EF30BF4
          9                        0x000000005EF3F3FC
          CLEAR                    0x000000005EF3B3FC
          0                        0x000000005EF373FC
          ENTER                    0x000000005EF333FC
      end codes

end remote[/code]

What do you think is wrong?  Do I need a different file for my remote?  If
so do I need to recompile again?  Any suggestions at all???

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Rick Strobel
Sent: Saturday, December 10, 2005 10:15 AM
To: mythtv-users at mythtv.org
Subject: [mythtv-users] TiVo remote on KnoppMyth

I've been trying really really hard to get a TiVo remote working with MythTV
- so hard in fact that Google has blocked my IP address because they think
I'm launching a DOS attack! 

What I've done so far: 

Installed R5A16 successfully 
Played a test video that I downloaded 
Used an ATI Remote Wonder that came with an old 9700 AIW card 
Bought and hooked up a homebrew IR receiver to my serial port (from
Read countless threads on mysettopbox.tv and other sites looking for
information on this that would apply to me. 
Renamed the TIVO file to lircd.conf in /etc/lirc 
Ran lirc-reconfig.sh (not sure I answered the questions correctly) 

What I don't understand: 

Does LIRC run automatically on a standard install? 
- if I type lircd from a prompt it appears to start, if I do it again I get
an error that it's already running 

Do I have to recompile LIRC for the TiVo remote to work? I was hoping not,
but I think I read that somewhere along the way. I saw a page on the wiki
about doing this but it looks pretty daunting and hard to follow. 

How can I tell if my serial port is working and do some basic tests of this

A whole bunch of things... I'm a computer pro with 20 years experience but a
Linux n00b. I've got a pretty good understanding of Linux conceptually but
have never compiled any programs with it or done much more than some
superficial things. 

I've probably spent 5 hours trying to figure this out on my own using the
mantra "Google is your friend", but am still coming up short. Thanks in
advance for any help!

More information about the mythtv-users mailing list