[mythtv-users] Re: Strange MythBackend troubles

Kirk Davis Kirk.Davis at epsb.ca
Thu Dec 8 10:00:05 EST 2005


> -----Original Message-----
> On Tue, 2005-12-06 at 16:49 -0500, Mike Frisch wrote:
> > On Mon, Dec 05, 2005 at 11:26:44PM -0800, Jeff Clemens wrote:
> > >    So occasionally, my master backend gets into a strange 
> state.   I have a
> > >    frontend and a backend running on each of 2 boxes.  
> The master backend
> > >    occasionally gets into a state where the frontend will 
> report that the
> > >    backend is down when trying some things (like deleting 
> a recording for
> > >    instance), but other menu items that use the backend 
> work fine.  When it's
> > >    in this state, neither frontend works correctly.
> > >    /sbin/service mythbackend restart fixes the problem 
> temporarily.
> > 
> > I cannot offer much other than to say the same thing 
> happens regularly
> > to me.  I cannot predict when it will happen but it happens somewhat
> > frequently.  It is as if the frontend loses track of the backend.
> I think this is what has happened to me on a few occasions, 
> the backend
> has stopped recording, the status page works still works but the
> frontend won't play but lists all the shows etc.
> Again a rcmythbackend restart fixed but I didn't discover 
> exactly why it
> happened.

    My system is also having the same problem.  It seems to loose the
connection with the backend when I try to delete a recording. The
frontend will eventualy time out but I have to restart the backend. 

    Here is some more information about my system that might help some
one track this problem down.
	Running on FC4 (2.6.14-1.1644_FC4smp) on a P4 3Gig with 1 Gig of
	Myth 18.1  from atrpms about 2 weeks ago.
	Two capture devices.  A PVR-150 and a firewire connection to a
DCT-6200 cable box.  
	The system is setup right off of Jarod's How-to from
	I'm using JFS for the filesystem that stores the recordings.
	Here are the ivtv packages that I am using:
	ivtv.i386                                1:0.4.0-98.rhfc4.at
	ivtv-firmware-audio.i386                 0.0.1-1.at
	ivtv-firmware-dec.i386                   2.02.023-4.at
	ivtv-firmware-enc.i386                   2.04.024-4.at
	ivtv-kmdl-2.6.14-1.1644_FC4smp.i686      1:0.4.0-98.rhfc4.at

    I hope this information helps. I just built up this new system.  The
old system was working without a hitch for almost 2 years.

---- Kirk

More information about the mythtv-users mailing list