[mythtv-users] mythbackend can't find channel is database

Mitko Haralanov voidtrance at comcast.net
Thu Dec 8 02:53:42 EST 2005

	After playing with the channel setup and number, I finally have
all the channels that I can receive over the air with their correct
channel number in the database and Zap2It with the correct listings.

	However, now I am having a problem getting mythbackend to find
the channels in the database so it can get the channel options. I get
the following messages in the log:

2005-12-07 23:41:31.131 DVB#0 Using DVB card 0, with frontend pcHDTV HD3000 HDTV.
2005-12-07 23:41:31.134 DVB#0 ERROR - Unable to find channel in database.
2005-12-07 23:41:31.135 DVB#0 ERROR - Failed to get channel options for channel .
2005-12-07 23:41:31.138 DVB#0 Recorder: Card opened successfully (using PS mode).
2005-12-07 23:41:31.149 DVB#0 ERROR - No PIDS set, please correct your channel setup.

	I know that the No PIDs message means that the staring channel
is invalid. I tried setting the starting channel to 2_1 (that channel is
in the database with that channel number) but I get the same message
and when I look in the database, the startchan field of the HD3000 in
the cardinput table is empty!!

	Is the problem that mythbackend does not know how to accept
channels of the form 2_1? If that is the problem, how should the
channels be represented?

Mitko Haralanov
voidtrance at comcast dot net
You will not be elected to public office this year.

More information about the mythtv-users mailing list