[mythtv-users] mythfrontend hangs, X is locked, cpu usage skyrockets

myth joe mythjoe at gmail.com
Wed Dec 7 01:28:40 EST 2005

What's the resolution to this?  I just upgraded my system from FC3 to
FC4 (new nvidia drivers, 0.18 -> 0.18.1, etc) installed from AT's
packages.  I have the exact same problem.

On 5/26/05, Ramzy Darwish <ramzy.darwish at gmail.com> wrote:
> Hello,
> I have scoured the archives looking for an answer to my problem. Somehow, I
> have totally screwed up my installation of mythfrontend. The backend seems
> to be working just fine, but somehow, I mucked things up and my frontend
> won't start correctly.
> I just upgraded my video card drivers and they seem to be happy with X all
> alone. But if I start mythfrontend, the "Prescaling images" dialogs appear,
> progress and disappear, but then the frontend just hangs there.
> And if I check top, my cpu usage is at like 97/98% with X gobbling all of
> it. I can't kill mythfrontend and the only thing that seems to work is to
> kill X manually and forcefully. I can't use the mouse or keyboard within X
> and I can't get to a command-line. If I have an ssh session open to the
> machine though, I can do stuff no problem. So the machine is not dying, just
> something about the interaction of X and mythfrontend. I did just upgrade to
> .18.1 and everything was going fine.
> THe only change I have made is my video card drivers. I did try to reinstall
> the old ones and uninstall the new ones etc., but this made both the NVIDIA
> installer and emerge (gentoo) angry and the only thing I am now able to do
> successfully is install the newest driver from the Nvidia installer.
> I don't really know what to look for. No errors show up in any logs (i.e.
> system or mythbackend).
> If I run mythfrontend -v all | tee output, I get:
> 2005-05-26 23:26:10.595 New DB connection, total: 1
> Total desktop width=640, height=480, numscreens=1
> 2005-05-26 23:26:10.610 Using screen 0, 640x480 at 0,0
> 2005-05-26 23:26:10.620 mythfrontend version:
> www.mythtv.org
> 2005-05-26 23:26:10.622 Enabled verbose msgs :all
> 2005-05-26 23:26:10.974 max_width: 640 max_height: 480
> 2005-05-26 23:26:11.136 Switching to square mode (Titivillus)
> 2005-05-26 23:26:11.477 /root/.mythtv/joystickmenurc not found.
> 2005-05-26 23:26:11.479 Joystick disabled.
> 2005-05-26 23:26:11.500 New DB connection, total: 2
> 2005-05-26 23:26:11.625 Registering Internal as a media playback plugin.
> 2005-05-26 23:26:11.661 Registering MythDVD DVD Media Handler as a media
> handler
> 2005-05-26 23:26:11.665 Registering MythDVD VCD Media Handler as a media
> handler
> 2005-05-26 23:26:12.286 Registering MythMusic Media Handler as a media
> handler
> 2005-05-26 23:26:12.667 generating cache image for:
> /usr/local/share/mythtv/them
> es/default/blank.png
> 2005-05-26 23:26:13.221 Starting media monitor.
> Now, I don't know if it necessarily means anything that the media monitor
> message is the last because I can start and use mythfrontend (somewhat) over
> a VNC connection. I can start mythfrontend and the menu comes up just fine
> and I can move around and even watch recordings (not actually watch, but
> they show up and I can play them).
> I did look into the media monitor problems some people had and tried
> disabling "Monitor CD/DVD", but that did nothing.
> I don't know how I screwed it up this bad. I did try reinstalling myth and
> mythplugins, but that didn't work.
> I really have been loving my system for over a year now and this has been
> the first big problem since getting it set up initially.
> Please let me know what other info you need me to let you know. I did
> compile mythtv with debug support, so I can send a stack trace if need be,
> but since there is not a crash or anything, I wonder if that's what is
> needed.
> Sorry if I'm not giving you much to go on, I really want to be helpful to
> all you wonderful people who have helped me in the past. Be gentle ;)
> Some info on my system:
> OS: Gentoo
> CPU: Dual P3 1000Mhz
> Video Card: Nvidia GeForce 4 440 MX
> Previous version of driver: 1.0-6111
> Current version of driver: 1.0-7174 (and they seem to be working)
> uname -a: Linux frontend1 2.6.10-gentoo-r6 #6 Sat Mar 26 17:18:25 CST 2005
> i686 Pentium III (Coppermine) GenuineIntel GNU/Linux
> I hope this is the type of info you need. I didn't change any config files
> or anything when I upgraded drivers.
> Thanks in advance,
> ramzy
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list