[mythtv-users] Configuring SPDIF digital out.

Mat Kyne matkyne at hotmail.com
Tue Dec 6 11:07:47 EST 2005

I  recently replaced my home theatre reciever with one that has digital 
inputs (old one was  5.1 analog), 2 coax and 1 optical.  Naturally I would 
like to get the best sound from my  HD-MythTV box,  (that might be the 
reason I bought the new reciever but don't tell that to my wife), so I 
removed the SB Live! 5.1 (analog) sound card that i had installed, went into 
the BIOS settings and enabled the onboard soundcard  that has a SPDIF coax 
connector.  When I rebooted, KDE told me that it could not find the sound 
card, So I went under System Settings - Soundcard Detection, and it foud it 
rightaway. Cool. ( I have the line out  from the mother board connected to 
my TV and the Coax connected to my reciever) Sound comes out of the Tv but 
not the reciever. I go into Myth Frontend, and select a HD  recording to 
play, Again sound out of the TV but not the reciever.  I then gointo 
settings and switch between the 3 settings available to me, and when i try 
to play a HD recording Myth informs me that it cannot find the sound card. 
Well at this time i figure that the ALSA mixer has muted the SPDIF connector 
so I  try to open up alsamixer and get the following error message:
alsamixer: function snd_ctl_open failed for default: No such file or 

I tried to google that, but I only found people who had the same error 
message, not what  they had done to fix it.  I tried looking in my 
/etc/modprob.conf file:

alias eth0 sk98lin
options snd-emu10k1 index=0
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-emu10k1
alias char-major-81 cx8800
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394
# nvidia kernel module
alias char-major-195 nvidia-1_0-7174
alias nvidia nvidia-1_0-7174
options snd-intel8x0 index=1
remove snd-intel8x0 { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || :
; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || :
; }; /sbin/modprobe -r --ignore-remove snd-intel8x0

and I am not sure what to do with it. The options snd-intel8x0 index=1 line 
is refering to my newly detected sound caard, and the emu10k1 is the old 

Also if I type aplay -l, the following is displayed:

**** List of PLAYBACK Hardware Devices ****
card 1: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 - 
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I am at a loss for what to do.  Sorry for the long post, but I wanted to 
give as much information as possible. -Mat

More information about the mythtv-users mailing list