[mythtv-users] Problems Connecting mythfrontend to remote backend

Doug Webb DougWebb at shaw.ca
Sun Dec 4 18:59:51 EST 2005

Sounds like the firewall was re-enabled when you upgraded the OS.


Mike Smith wrote:

>I've been dealing with this problem for a week now
>without resolution.
>I'm running an application called mythtv which uses
>mysql as its database.
>I've installed mythtv and mysql dozens of times
>without any problem.
>I'd been running two Mandrake 10.1 systems for the
>last nine months. One,
>gandalf, was the mythtv backend server which also runs
>mysql.  The other is
>frodo, which runs the mythtfrontend ( client ) and
>connects to the backend.
>It must also connect to the mysql DB.
>MySQL-4.0.20-3mdk.i586.rpm comes with
>the Mandrake 10.1 distribution.  I don't know which
>version of mysql that
>equates to.
>I first installed Mandrivia 2006 on the client system,
>which comes with 
>Mysql 4.1.2 ( MySQL-4.1.12-3mdk.i586.rpm ).  I did an
>install, not an
>upgrade.  I could still connect to gandalf with:
>mysql -umythtv -pmythtv -hgandalf mythconverg
>I then did a mysqldump on mythconverg and install
>Mandrivia 2006 on 
>server gandalf.  I restored the mythconverg;  Now,  I
>[root at frodo# mysql -u mythtv -pmythtv -h gandalf
>ERROR 2003 (HY000): Can't connect to MySQL server on
>'gandalf' (111)
>I then tried granting privledges to mythconverg using
>on the server
># mysql -u root mythconverg
>mysql> grant all on mythconverg.* to mythtv@"%"
>identified by "mythtv";
>mysql> flush privileges;
>Still can't connect.
>I booted off the old installation and did a mysql dump
>of mysql database
>and did inserts of the appropriate tables, like the
>user table.  Still
>can't connect.
>I've droped the mythconverg database, recreated a
>skeleton of it, granted
>the open privledges and still can not connect to it.
>Another fact:  on the server gandalf,  I can connect
>to the database
>as localhost, but not if I specify the host:
>gandalf# mysql -u mythtv -pmythtv mythconverg         
>        Success!!
>gandalf# mysql -u mythtv -pmythtv -h gandalf
>mythconverg        Failure!!
>gandalf# mysql -u mythtv -pmythtv -h
>mythconverg     Failure!!
>gandalf# mysql -u mythtv -pmythtv -h
>mythconverg     Success!!
>gandalf# mysql -u mythtv -pmythtv -h localhost
>mythconverg      Success!!
>I've already check my /etc/my.cnf file for a "binding"
>line.  Its not 
>there.  I also found an item online that indicated
>to /etc/my.cnf was needed for mysql under Mandrake. 
>Still no help.
>Also,  I can resolve the name/ip of both hosts from
>both hosts.  I
>can ping each host ( by name ) both ways.  I can ssy (
>by name ) between
>both hosts.
>Start your day with Yahoo! - Make it your home page! 
>mythtv-users mailing list
>mythtv-users at mythtv.org

More information about the mythtv-users mailing list