[mythtv-users] [Semi-OT] Intel 2200 Wireless chipset with Myth...

Louie Ilievski loudawg at comcast.net
Sat Dec 3 21:17:23 EST 2005

On Saturday 03 December 2005 01:27 pm, Darren Black wrote:
> I just bought myself a Dell Inspiron 6000 laptop (wasn't keen on buying
> Dell, but the price was good and it's a surprisingly nice machine). The
> machine contains an Intel 2200 wifi card as part of the Centrino package.
> My attempts to get the card working well in FC4 have been, well... ugly
> would probably be the best word. That's perhaps a little beside the point
> of this post.
> What I'm really wondering is if anybody here uses such a card under linux
> to stream TV/recordings over. In the times I have actually had the card
> functioning, the wireless connection was unable to sustain a constant
> stream (without pausing and jitter). My streams are from a PVR150 card and
> encoded at up to 8500kbit/sec. I have tried turning the bitrate down to
> 6500 which helped, but not for very long. My previous wireless gear was
> some DLink "b+" standard equipment. My current router is a Linksys WRT54GS.
> I should be getting better throughput with this setup, however this is not
> the case in Linux (to this point at least). Performance in Windoze is alot
> better - the same recordings play back problem free using dsmyth.
> I suspect that my inability to configure the card correctly is the cause of
> the poor performance, but I'd like some feedback to either confirm or
> disprove this hypothesis. So do let me know :-)
> Cheers,
> /drdaz

I had an issue as well, and there are two things I did that made it work fine 
(although I haven't used my laptop a whole lot lately for mythtv):

First, put your router in G-only mode, if possible.  This increases the 
throughput by a considerable amount (for me, mixed mode gave me around 1 
meg/sec transfers, while G-only mode gave me around 2 megs/sec).

For the ipw2200, I noticed that when trying to stream mythtv stuff, I get a 
lot of errors in dmesg regarding the firmware messing up or something.  I 
think this is due to hardware encryption.  If you use WEP on your network, 
then add the module parameter hwcypto=0.  This eliminated that issue for me.

These two things made everything stream just fine for me even at pretty high 
bitrates.  I did LiveTV before and it worked ok.


More information about the mythtv-users mailing list