[mythtv-users] OT: LIRC on Gentoo with new Nova-T

Robin Elvin rob at fearsedge.com
Sun Aug 28 08:48:08 UTC 2005


On Saturday 27 August 2005 10:28, Jens Baumeister wrote:
> Hi,
> 
> I know it's not a LIRC-list, but Im postign this here in case someone
> recognizes this problem and konows of a quick solution:
> 
> I'm on Gentoo, running the vanilla-sources 2.6.10-kernel with the
> bytesex.org-patches to get my TV card working. It's a Nova-T, Model
> 928. That's Connexant-based and with the IR-reciver connected to the
> card itself.
> 
> Actually, I have 2 of those cards - don't know if that makes a
> difference when setting up LIRC. (v. 0.7.0-r1)
> 
> I tried following various tutorials to get LIRC going, mainly this one:
> 
> http://gentoo-wiki.com/HOWTO_LIRC
> 
> and I took some hints for i2c kernel modules from this one
> 
> http://home.comcast.net/~alf_park/mythtv.html
> 
> (although 'm not 100% sure I got the correct chipsets enabled... :-( )
> 
> I also used a lircd.conf file posted to the group a few days ago.
> 
> Right now, this is the state of the system:
> 
> I can start lircd with -d /dev/lirc0, but afterwards, I only have
> /dev/lircd, not /dev/lirc0
> 
> modprobe lirc-i2c gives an error message:
> FATAL: Module lirc_i2c not found.
> I tried depmod -ae to make it show up - no luck.
> 
> irw starts but drops me directly back onto the command line. Any
> subsequent attempt to start it results in a "Connection refused" until
> I restart lircd.
> 
> Pressing the "OK"-button on the remote seems to be recognized as a
> "Return"-keypress by the system, any other buttons are ignored.
> 
> The fact that the system reacts to the remote at all makes me think
> that it should be possible to get this working, however I have
> absolutely no idea where to go from here.
> 
> Any hints would be appreciated.
> 
> Thanks
> 
> Jens
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> 

Hi.

If it's anything like my Nova-T (90002) then the IR driver adds another "keyboard". Try

cat /proc/bus/input/devices

You should see something like:

I: Bus=0001 Vendor=0070 Product=9002 Version=0001
N: Name="cx88 IR (Hauppauge Nova-T DVB-T"
P: Phys=pci-0000:00:0c.2/ir0
H: Handlers=kbd event2
B: EV=100003
B: KEY=103fc282 2002001 0 0 6303ff 0 118000 4180 801 9e0044 0 800000 0

As you can see mine has added an event2 handler to /dev/input/

You can then configure your lircd to look for input from there:

LIRCD_OPTS="--driver=dev/input --device=/dev/input/event2 -p 666 /etc/lircd.conf"

At least it might point in the right direction. I tried to Google but I couldn't find anything related to lirc and the 928.

-- 
Rob


More information about the mythtv-users mailing list