[mythtv-users] Unable to initialize video - was working before

SÚrgio Gaspar smmg at nukitel.com
Mon Aug 22 11:59:37 UTC 2005


Hi,

I am assembling a mythtv system on my spare time (which is not much)
made of an Athlon64 on a nForce3 chipset, two PVR-500MCE cards, one
PVR-350 and an AGP 8x Geforce 6200 card with S-Video out. I am using the
S-Video out on the nVidia card for connecting to the TV and image
quality on the TV is reasonably good when using XvMC, but not so good
without XvMC. I insist on using the Geforce for video out, as I will try
to connect it to the SCART on the back of the TV set using RGB for
better quality.

Now, my problem is that after about two months without spare time I
tried to use the system, but when I try to watch TV I get the "Unable to
initialize video" error, but it was working two months ago, why not now?
No configuration had been changed since, as the system had not been
used.

While experimenting a little to solve this issue I was able to watch TV
twice but strangelly it only happened after using the nvidia-settings
application for increasing the overscan value and then decreasing it,
but not on the same X session. The first time I run mythfrontend after
doing this got XvMC working twice, nothing I could do would get it
again, including desperate solutions like powering the system off and
then back on.

Since then I tried different versions of the nvidia kernel module, with
no results.

mythtv is version 0.18.1, nvidia kernel module versions 1.0.6629,
1.0.7676 and 1.0.7174 have been tried along with corresponding
nvidia-glx versions. The Linux distribution I am using is Gentoo.

Without XvMC I get lower resolution choppy video (unpleasant to watch),
and after a while (30 seconds is enough) the system does not respond to
the remote control or to the keyboard. I believe an Athlon 64 3000+
(Venice core) should be enough for decoding a few streams of MPEG2
video, in fact, mplayer plays a DVD in full screen with much more
quality and much less choppyness, and unfortunatelly I can only stop it
with Ctrl+Alt+Backspace when run from mythfrontend.

Another strange thing I noticed was that the overscan on the TV set was
insuficient, same setting as two months ago, but I suspect that has
probably to do with variance with temperature on the analog circuitry of
the TV set.

Any ideas on the "Unable to watch video" issue? 


Thanks in advance, and sorry for the very long description.

Sergio




More information about the mythtv-users mailing list