[mythtv-users] Re: GUI Y-offset setting not honored when watching a show

Chris Strom chris.eee at gmail.com
Tue Apr 19 00:12:45 UTC 2005

On 4/18/05, Michael J. Sherman <msherman at dsbox.com> wrote:
> >  On 4/17/05, Michael J. Sherman <msherman at dsbox.com> wrote:
> > > I have to set my X- and Y-offsets to non-zero numbers to get the GUI
> > > and TV image to line up right on my television set. I just upgraded
> > my
> > > myth CVS, and noticed that now when I go into watch TV or a
> > recording,
> > > the GUI Y-offset is not taken into account like it has been (so when
> > it
> > > switches to xv). So, everything is shifted up too much. When I exit
> > > out back to the GUI, it keeps it all shifted up and I have to exit
> > out
> > > and come back in the frontend for it to reset the position.
> >
> > When you say non-zero, do you mean less than zero or just a little
> > more than zero (e.g. 2)? Right before the .18 release, there were
> > some GUI/player positioning issues with certain window managers. I
> > believe that the ultimate solution was to reset the GUI/player windows
> > to (0,0) if the current position was less than (3,3). The assumption
> > being that this would address the strangeness in certain window
> > managers, but not have an impact on anyone else. Perhaps that was
> > wrong?
> >
> >
> By non-zero I mean like 20, so it's not the few pixel issue of before,
> but perhaps the "fix" did mess up the normal functioning of the offset
> for larger values.
> Can you point me to the source file that has this code in it?  I can
> take a look around.

The Init method of mythtv/libs/libmythtv/tv_play.cpp.  Hope that helps!


More information about the mythtv-users mailing list