[mythtv-users] Going Nuts re: Nvidia Setup

Larry K lunchtimelarry at gmail.com
Mon Apr 4 01:21:53 UTC 2005


I have been struggling to get my nvidia environment set up according to 
Jarod's guide. Let me start by saying that altho I am relatively new to the 
Linux world, I have a pretty solid foundation to build on. However, this 
little project is doing very little for my self-esteem. :)

Here is my system:

Nforce2 Crush 18G IGP chipset +Southbridge MCP
Athlon XP 2500+
Geforce4 MX 440 AGP (S-video TV-out)
FC core 3 kernel 2.6.10-1.770
Nvidia 6629 driver
Dell Flat Panel 1703FP VGA (analog)

When I run KDE with the default xorg.conf file (nv driver), things appear to 
work correctly on the Dell monitor. Having succeeded with that, I tried 
installing the nvidia xorg.conf, which is where the problems begin. When the 
KDE desktop opens, the icons are not painted correctly, and when I click on 
things, the display is *somewhat* garbled. I can normally see things well 
enough to do a shutdown, but that's about it. 

I have experimented with about 1E10 permutation of settings, with varying 
degrees of limited success. I have tried various settings of the NvAGP 
option, to no avail. I have disabled ACPI in the system BIOS. I tried the 
mem=nopentium switch as described in the nvidia readme Appendix F. I read 
about blacklisting AGPGART via /etc/hotplug/blacklist, but didnt get too far 
with that one..

When I cat /proc/driver/nvidia/agp/status, it sometimes says that AGP is not 
enabled, or some such message. At other times, that nvidia directory is not 
even there at all.

dmesg normally reports something like this: 
agpgart: Detected NVIDIA nForce2 chipset
agpgart: Maximum memory....

/var/log/messages reports something like this:
nvidia: module license 'NVIDIA" taints kernel
NVRM: loading nvidia 6629....
NVRM: not using NVAGP, AGPGART is loaded!!

I have stopped progress at chapter 7 of Jarod's guide. I suspect I have some 
fundamental flaw in my AGP environment that I must solve before I continue 

So....Given my situation...

Would I be better off with FC 2 versus FC 3?
What nvidia driver should I use? 6629?
Do I want agpgart? Does this conflict with the nvidia driver? or complement 
it? If I don't want this, how do I disable it? 
What NvAGP setting do I need in xorg.conf? I think I want NVAGP (1).

What could be making it so difficult to get this nvidia xorg.conf to work 
properly? Eventually, I plan to use the S-video TV-out, but if I can't make 
the video driver work on a simple VGA connection, I should not tackle TV-out 
or God forbid, twinview! At least, not yet.

Please help before I go postal.

P.S. Earlier this month, I had successfully built mythtv on a FC 2 setup, 
altho I never got TV-out or twinview set up properly. Then, in a moment of 
idiocy, I started over with FC 3, which is proving to be more difficult than 
FC 2, it seems.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20050403/f748e016/attachment.htm

More information about the mythtv-users mailing list