[mythtv-users] nuvexport beta available

Cory Papenfuss papenfuss at juneau.me.vt.edu
Mon Sep 27 09:16:33 EDT 2004

 	Oh, and if anyone else uses Encap to sort out stuff in /usr/local, 
here's a slightly modified install script:



sudo mkdir -p ${PREFIX}
sudo chown ${OI}:${GI} ${PREFIX}
mkdir -p ${PREFIX}/bin
mkdir -p ${PREFIX}/share

# First, install nuvexport itself
     install -Dv -o ${OI} -g ${GI} -m 0755 nuvexport ${PREFIX}/bin/nuvexport
     install -Dv -o ${OI} -g ${GI} -m 0755 nuvinfo   ${PREFIX}/bin/nuvinfo
     install -Dv -o ${OI} -g ${GI} -m 0755 mpeg2cut  ${PREFIX}/bin/mpeg2cut

# Next, create the nuvexport shared directory
     mkdir -pvm 0755 ${PREFIX}/share/nuvexport

# Finally, install the other files
     for dir in 'export' 'mythtv' 'nuv_export'; do
         mkdir -pvm 0755 ${PREFIX}/share/nuvexport/"$dir"
         install -v -o ${OI} -g ${GI} -m 0755 "$dir"/*pm 

#Populate symlinks in /usr/local/

sudo epkg -i nuvexport

* Cory Papenfuss							*
* Electrical Engineering candidate Ph.D. graduate student               *
* Virginia Polytechnic Institute and State University 			*

On Mon, 27 Sep 2004, Brian McSpadden wrote:

> Tom,
> You are having the same problem I had..You are missing the Time::HiRes
> perl module.Here's what I did to fix it:
> 1. From the command line, (probably need to be root), run the command cpan
> 2. It may ask you about configuration stuff...if you need to configure
> a proxy, etc, type yes, otherwise, type no and let it autoconfigure.
> 3. Once you get to a prompt, type "install Time::HiRes" (without the
> quotes). It will go ahead and download and install the module. After
> that, nuvexport should load up like a charm!
> Brian
> On Mon, 27 Sep 2004 02:24:11 -0400, Tom E. Craddock, Jr.
> <sigtom at sigtom.com> wrote:
>> Chris Petersen wrote:
>>> So after much cramming (because I was running out of drive space) by
>>> myself and Gavin (aka Beirdo), I am officially announcing the beta
>>> release of the new version of nuvexport, available here:
>>> http://forevermore.net/files/nuvexport_beta.tar.bz2
>>> These changes are NOT in cvs (yet), and the file will change as bugs
>>> are found/fixed.  I'm also not organized to have a real change list,
>>> but here is the gist of it:
>>> Near-complete rewrite from the ground up.  The original nuvexport was
>>> a hack, and I didn't know much of anything about transcoding, or plan
>>> much for it to be used for anything more than svcd exporting (so it
>>> got messy as people submitted new modules).  Other than the nuv+sql
>>> and mpeg2cut modules, everything now uses the transcode program,
>>> rather than having separate transcode/nontranscode modules (there was
>>> a lot of confusion since the old "transcode" modules only worked with
>>> mpeg2 files). nuvexport will auto-detect the type of file being
>>> transcoded, and use mythtranscode/fifos accordingly.
>>> You can now select multiple shows for export (the menus should be
>>> pretty easy to understand -- please note the addition of a "confirm"
>>> stage, and that adding a "show" with only one episode auto-adds that
>>> episode and skips you straight to "confirm").
>>> There is now a progress indicator (it's about 99% accurate), and all
>>> of the confusing transcode/whatever output is hidden.  I still need to
>>> add code to properly pass errors through if something dies.  For now,
>>> --debug should still work as it used to.
>>> Commandline support is much more organized, but is still a bit lacking
>>> in this beta version.  There is no documentation for it as of yet,
>>> either.
>>> Other things to note..  recordings are now "cropped" before they're
>>> exported, to get rid of the broadcast overscan/black border stuff.
>>> This will eventually be an option, but I haven't had time to hook it
>>> up. Currently, 2-3% is taken off of each edge automatically.
>>> Eventually, we'll also add something for letterbox/widescreen
>>> cropping, too. Anyway, just keep this in mind when exporting your
>>> 640x480 recording, so that you are aware that exporting it to a
>>> 640x480 xvid file will actually be stretching the video taller/wider.
>>> Integration with mythweb, and the client/server mode are still on the
>>> horizon, but nowhere near functional yet in this version (mythweb
>>> integration will kick in as soon as the CLI stuff is finished).
>>> Things that still need to happen:  add ansi color support to menus
>>> (for titles, etc), finish cli/walkthrough separation, documentation,
>>> finish porting a few remaining modules, probably some other stuff that
>>> I can't think of at the moment.
>>> I can be reached here via email, the feedback form on forevermore.net
>>> or  often on #mythtv-users (I don't hang out much in the dev channel
>>> because most of what goes on there is over my head).  And please
>>> remember, this is a beta.  That means it is probably unstable, could
>>> wipe your drive, cause hurricanes and/or spontaneously combust nearby
>>> politicians.
>>> -Chris
>>> _______________________________________________
>>> mythtv-users mailing list
>>> mythtv-users at mythtv.org
>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>> Chris,
>> First off, thanks for the beta.  Been looking forward to backing up alot
>> of my recordings.  I tried the beta on yer site a couple of days ago,
>> couldnt get it to work, so just waited till you posted this.  Went and
>> got the latest version on yer site, and still getting the same
>> problems.  Im running FC2 using Jarods Guide, atrpms.net, etc.  I use
>> the install.sh, it does its thing, and then when I try to use the
>> program, I get the following below:
>> [root at sigmachi nuvexport]# sh ./install.sh
>> `nuvexport' -> `/usr/local/bin/nuvexport'
>> `nuvinfo' -> `/usr/local/bin/nuvinfo'
>> `mpeg2cut' -> `/usr/local/bin/mpeg2cut'
>> mkdir: created directory `/usr/local/share/nuvexport/export'
>> `export/DVCD.pm' -> `/usr/local/share/nuvexport/export/DVCD.pm'
>> `export/DVD.pm' -> `/usr/local/share/nuvexport/export/DVD.pm'
>> `export/generic.pm' -> `/usr/local/share/nuvexport/export/generic.pm'
>> `export/MPEG2_cut.pm' -> `/usr/local/share/nuvexport/export/MPEG2_cut.pm'
>> `export/NUV_SQL.pm' -> `/usr/local/share/nuvexport/export/NUV_SQL.pm'
>> `export/SVCD.pm' -> `/usr/local/share/nuvexport/export/SVCD.pm'
>> `export/transcode.pm' -> `/usr/local/share/nuvexport/export/transcode.pm'
>> `export/VCD.pm' -> `/usr/local/share/nuvexport/export/VCD.pm'
>> `export/XviD.pm' -> `/usr/local/share/nuvexport/export/XviD.pm'
>> mkdir: created directory `/usr/local/share/nuvexport/mythtv'
>> `mythtv/db.pm' -> `/usr/local/share/nuvexport/mythtv/db.pm'
>> `mythtv/nuvinfo.pm' -> `/usr/local/share/nuvexport/mythtv/nuvinfo.pm'
>> `mythtv/recordings.pm' -> `/usr/local/share/nuvexport/mythtv/recordings.pm'
>> mkdir: created directory `/usr/local/share/nuvexport/nuv_export'
>> `nuv_export/shared_utils.pm' ->
>> `/usr/local/share/nuvexport/nuv_export/shared_utils.pm'
>> `nuv_export/task.pm' -> `/usr/local/share/nuvexport/nuv_export/task.pm'
>> `nuv_export/ui.pm' -> `/usr/local/share/nuvexport/nuv_export/ui.pm'
>> [root at sigmachi nuvexport]# nuvexport
>> Can't locate Time/HiRes.pm in @INC (@INC contains: /usr/local/bin
>> /usr/share/nuvexport /usr/local/share/nuvexport
>> /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi/5.8.3/i386-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi/5.8.3
>> /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi/i386-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi/5.8.2
>> /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi/5.8.1
>> /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi/5.8.0
>> /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.3/5.8.3/i386-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.3/5.8.3
>> /usr/lib/perl5/site_perl/5.8.3/5.8.2
>> /usr/lib/perl5/site_perl/5.8.3/5.8.1
>> /usr/lib/perl5/site_perl/5.8.3/5.8.0 /usr/lib/perl5/site_perl/5.8.3
>> /usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
>> /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1
>> /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
>> /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
>> /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
>> /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
>> /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
>> /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
>> /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
>> /usr/lib/perl5/vendor_perl .) at
>> /usr/local/share/nuvexport/nuv_export/shared_utils.pm line 11.
>> BEGIN failed--compilation aborted at
>> /usr/local/share/nuvexport/nuv_export/shared_utils.pm line 11.
>> Compilation failed in require at /usr/local/bin/nuvexport line 18.
>> BEGIN failed--compilation aborted at /usr/local/bin/nuvexport line 18.
>> [root at sigmachi nuvexport]#
>> Im kind of out of my element, Im not sure if its telling me I dont have
>> something installed, or what it means.  Thought Id post it here to see
>> if you (or others) could help.  Thanks in advanced.
>> Tom E. Craddock, Jr.
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list