[mythtv-users] recording static with 350

Michael T. Dean mtdean at thirdcontact.com
Mon Sep 20 13:15:58 EDT 2004

On 09/19/2004 08:03 AM, Lee Sobotkin wrote:

>I have tried several times, using Jarod's guide, to get my 350 working.  I
>know it is untested with c2 but I could not get it with c1 either.  All I
>get is static even when changing channels.

># ivtv modules setup
>alias char-major-81 videodev
>alias char-major-81-0 ivtv
>alias char-major-61 lirc_i2c
>options ivtv ivtv_debug=1 tuner=2
>options saa7127 enable_output=1 output_select=1
>install ivtv /sbin/modprobe msp3400 saa7115 tuner v4l1-compat;
>/sbin/modprobe --ignore-install ivtv; /sbin/modprobe ivtv-fb
>install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install
>options msp3400 once=0 simpler=1 simple=0
With current ck patches to ivtv, you should not specify all these 
options in modprobe.conf.  Instead allow the drivers to do the work for 
you.  There are two problems causing you grief:  the first is that you 
are specifying the wrong tuner type (type 2 when you have type 47), 
which overrides the autodetection the drivers are trying to do for you; 
the second (which may require a bit more work to fix) is explained below.

So, first, change your modprobe.conf to:

# ivtv modules setup
alias char-major-81 videodev
alias char-major-81-0 ivtv
alias char-major-61 lirc_i2c
install ivtv /sbin/modprobe --ignore-install ivtv; /sbin/modprobe ivtv-fb
install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install 

(Basically, no options for ivtv modules, and only use the install lines 
to load ivtv-fb after ivtv (all other dependent modules are 
automatically loaded for you).  The framebuffer (ivtv-fb) is not 
automatically loaded for those of us who decided not to use the PVR-350 
TV out.  Loading ivtv before lirc_i2c is also recommended for the 

>Sep 18 20:56:39 localhost kernel: tveeprom: Hauppauge: model = 48132, rev =
>K168, serial# = 7336125
>Sep 18 20:56:39 localhost kernel: tveeprom: tuner = LG NTSC (TAPE series)
>(idx = 68, type = 47)
>Sep 18 20:56:39 localhost kernel: tveeprom: tuner fmt = NTSC(M) (eeprom =
>0x08, v4l2 = 0x00001000)
>Sep 18 20:56:39 localhost kernel: tveeprom: audio_processor = MSP3440 (type
>= 11)
The second problem is that you have a brand new LG TAPE tuner.  The 
tuner is not yet supported by the kernel (as of Linux, but 
2.6.9-rc2 has support for it); therefore, if you're using the tuner (as 
opposed to S-Video or Composite input), you'll have to patch your 
kernel's tuner module or upgrade to 2.6.9-rc2.  The patch for Linux are available at 
http://www.poptix.net/ivtv/Sep-2004/msg00299.html . 

Note that if you do not patch your tuner module, you can specify

options ivtv tuner=39

(which uses a different tuner definition (the LG NTSC (newer TAPC 
series) tuner)--that's close, but incorrect--to get support for channels 
up to 61 (inclusive).  Every channel above that will be static.)


More information about the mythtv-users mailing list