[mythtv-users] Fresh FC1 and Myth 0.16 install observations/questions

Michael J. Lynch mlynch at gcom.com
Mon Sep 20 09:24:40 EDT 2004

Last weekend I replaced my KnoppMyth install with a fresh install of FC1 
(using Jarod's FC1 guide) and Myth 0.16.  I didn't want to use FC2 
because of problems with Xorg's drivers for my video card that don't 
exist with XFREE86 and I didn't want to go down the road of trying to 
get XFREE running on FC2.   The following are my observations along with 
a couple of questions.

    1.  Error occuring when creating database.  This is the same error 
that a few other posts have mentioned.  It does not appear to affect 
anything and the database seems to work OK (at least for me).

    2.  Also mentioned in at least one other post, closed captioning has 
transparent instead of black background.  Is this configurable somewhere?

    3.  The sources.list file after "apt-get dist-upgrade" is 
significantly different than it was not too long ago.  Can not do 
"apt-get install gnome-alsamixer" unless freshrpms are added.  Are there 
any plans to correct this?

    4.  With 0.15, playback of recorded shows, my CPU idle time was 
~%60.  With 0.16, CPU idle time is ~%30 during playback.  I did select 
kernel deint in mythtvsetup, could this account for the large difference 
or is this more likely  a linux distro difference?

    5.  I ran mythfrontend from a terminal window and noticed a message 
about a call to "pthread_setpriority" failing because mythfrontend was 
not being run as "suid".  I changed permissions on mythfrontend to suid 
and the message went away.  Could this account for the CPU idle time 
difference above?  Should the front end be run suid or not?  Leaving it 
non-suid didn't seem to make anything bad happen, although it may be 
hard to tell because apparently the only thing it affects is playback 
quality (stutter/jitter).

Michael J. Lynch

What if the hokey pokey IS what it's all about -- author unknown

More information about the mythtv-users mailing list