[mythtv-users] prism54 under FC2 so I can use mythtv

Josh Bozarth josh.bozarth at gmail.com
Sun Sep 19 22:35:38 EDT 2004

I had a similar problem with the firmware not loading on boot like
that, but I found a post that said to just initialize the card from
rc.local. I basically copied the following script, named rc.wlan, and
then called that script from rc.local. My wireless is working great.
Note that I am not using WEP, it's basically wide open. I'm waiting on
WPA support from prism54. I also commented out some ifup and ifdown
statements that weren't helping me any. I also had to add the route
for the default gateway.

This is a hack at best, as I get an error when I shut down the PC.
But, it works for what I need it to, so it might work for you.

# rc.wlan

#KEY="1234-5678-1234-5678-1234-5678-12" # Change this to some random value

# Set up the WiFi card

echo "bringing down ${INTERFACE}"
ifconfig ${INTERFACE} down

# down and up external internet interface - this resets the kernel
routing tables as well
# Dont use ifconfig xxx down/up here
#ifdown eth1
#ifup eth1

echo "bring up ${INTERFACE}"
ifconfig ${INTERFACE} up

sleep 5

# configure it

echo "Configuring ${INTERFACE}:"
/sbin/ifconfig ${INTERFACE} ${IPADDR}
/sbin/iwconfig ${INTERFACE} channel ${CHANNEL}
/sbin/iwconfig ${INTERFACE} mode ${MODE}
sleep 5
#/sbin/iwconfig ${INTERFACE} key ${KEY}
/sbin/iwconfig ${INTERFACE} essid ${ESSID}
route add default gw eth1

On Sun, 19 Sep 2004 12:34:09 -0700, Mike Fenston
<fenston-myth at san.rr.com> wrote:
> I posted this message (below) to the prism54 website under fedora core
> section but figured I would try posting here as well.  This is sort of
> related to my mythtv setup as I need to get this working so I can put my
> Antec Aria box in the living room to run mythtv and there is no good way
> to get a hard wired ethernet connection out there.
> Here is my unanswered post from prism54.org ... If any of you RedHat
> gurus out there can help me it will be much appreciated.
> Thanks,
> -Mike
> I'm using Fedora Core 2 and have an SMC2802 PCI card. I've been hacking
> on this for awhile now and here is my current situation. I have a built
> in network card on eth0, and my prism54 compliant card on eth1.
> I have WEP enabled, and when I type:
> ifdown eth0
> ifup eth1
> I am able to ping past my linksys router and all is good. For awhile DNS
> did not appear to be working but once I ping'd past my linksys the DNS
> magically started working so I figured this was a victory ... wrong.
> I went to the network GUI tool and attempted to disable eth0 on boot and
> enabled eth1 on boot since it worked from the command line.
> For some reason when booting up ... IE: all those [ok] messages on
> startup ... it errors out. Sure enough - once I login, su - to root ,
> and ifup eth1 it works and I can ping out again.
> Any help appreciated. I really want to get this working as part of the
> standard boot up script so things like ntp work ok. Does this have
> something to do with the firmware loader?
> more info ...
> ok ... it looks like a problem with the request firmware during boot ...
> any ideas on a fix? I tried changing the permissions on
> /usr/lib/hotplug/firmware/isl3890 with a chmod 777 but no luck.
> from /var/log/messages
> Sep 18 20:45:53 localhost kernel: prism54: request_firmware() failed for
> 'isl3890'
> Sep 18 20:45:53 localhost kernel: eth1: could not upload firmware
> ('isl3890')
> here is what happens after boot:
> [root at localhost root]# ifup eth1
> interface 'eth1' not found
> Error for wireless request "Set Bit Rate" (8B20) :
> SET failed on device eth1 ; Input/output error.
> Determining IP information for eth1... done.
> [root at localhost root]#
> new /var/log/messages
> Sep 18 20:48:57 localhost kernel: ip_tables: (C) 2000-2002 Netfilter
> core team
> Sep 18 20:48:58 localhost dhclient: sit0: unknown hardware address type
> 776
> Sep 18 20:48:59 localhost dhclient: sit0: unknown hardware address type
> 776
> Sep 18 20:49:02 localhost dhclient: DHCPREQUEST on eth1 to
> port 67
> Sep 18 20:49:02 localhost dhclient: DHCPACK from
> Sep 18 20:49:02 localhost dhclient: bound to -- renewal in
> 33552 seconds.
> and all is good at this point.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

I got a pig at home in a pen
Corn to feed him on
All I need's a pretty little girl
To feed I'm when I'm gone

More information about the mythtv-users mailing list