[mythtv-users] prism54 under FC2 so I can use mythtv

Mike Fenston fenston-myth at san.rr.com
Sun Sep 19 15:34:09 EDT 2004

I posted this message (below) to the prism54 website under fedora core
section but figured I would try posting here as well.  This is sort of
related to my mythtv setup as I need to get this working so I can put my
Antec Aria box in the living room to run mythtv and there is no good way
to get a hard wired ethernet connection out there.

Here is my unanswered post from prism54.org ... If any of you RedHat
gurus out there can help me it will be much appreciated.



I'm using Fedora Core 2 and have an SMC2802 PCI card. I've been hacking
on this for awhile now and here is my current situation. I have a built
in network card on eth0, and my prism54 compliant card on eth1. 

I have WEP enabled, and when I type: 

ifdown eth0 
ifup eth1 

I am able to ping past my linksys router and all is good. For awhile DNS
did not appear to be working but once I ping'd past my linksys the DNS
magically started working so I figured this was a victory ... wrong. 

I went to the network GUI tool and attempted to disable eth0 on boot and
enabled eth1 on boot since it worked from the command line. 

For some reason when booting up ... IE: all those [ok] messages on
startup ... it errors out. Sure enough - once I login, su - to root ,
and ifup eth1 it works and I can ping out again. 

Any help appreciated. I really want to get this working as part of the
standard boot up script so things like ntp work ok. Does this have
something to do with the firmware loader?

more info ...

ok ... it looks like a problem with the request firmware during boot ...
any ideas on a fix? I tried changing the permissions on
/usr/lib/hotplug/firmware/isl3890 with a chmod 777 but no luck. 

from /var/log/messages 

Sep 18 20:45:53 localhost kernel: prism54: request_firmware() failed for
Sep 18 20:45:53 localhost kernel: eth1: could not upload firmware

here is what happens after boot: 

[root at localhost root]# ifup eth1 
interface 'eth1' not found 
Error for wireless request "Set Bit Rate" (8B20) : 
SET failed on device eth1 ; Input/output error. 

Determining IP information for eth1... done. 
[root at localhost root]# 

new /var/log/messages 

Sep 18 20:48:57 localhost kernel: ip_tables: (C) 2000-2002 Netfilter
core team 
Sep 18 20:48:58 localhost dhclient: sit0: unknown hardware address type
Sep 18 20:48:59 localhost dhclient: sit0: unknown hardware address type
Sep 18 20:49:02 localhost dhclient: DHCPREQUEST on eth1 to port 67 
Sep 18 20:49:02 localhost dhclient: DHCPACK from 
Sep 18 20:49:02 localhost dhclient: bound to -- renewal in
33552 seconds.

and all is good at this point.

More information about the mythtv-users mailing list